summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-09-14 16:00:10 +0200
committersL1pKn072021-09-14 16:00:10 +0200
commit636bd0d6f9b2a5aa8c348dd0501c992609005c8c (patch)
tree3f66304d560a6b0f920dfc948138e75e30e4df8c
parent0f8f9cb7108bfd560c9dd373ea29c1967ee84c37 (diff)
downloadaur-636bd0d6f9b2a5aa8c348dd0501c992609005c8c.tar.gz
sync with [core]
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3ed9b7b9963..befcaeca5f4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = lib32-libarchive
pkgdesc = library that can create and read several streaming archive formats (32 bit)
- pkgver = 3.3.3
+ pkgver = 3.5.2
pkgrel = 1
url = http://libarchive.org
arch = x86_64
license = BSD
- makedepends = gcc-multilib
- makedepends = lib32-zlib
depends = lib32-acl
depends = lib32-bzip2
depends = lib32-expat
- depends = lib32-lzo
+ depends = lib32-lz4
depends = lib32-openssl
depends = lib32-xz
- depends = libarchive
- source = http://libarchive.org/downloads/libarchive-3.3.3.tar.gz
- sha512sums = 9d12b47d6976efa9f98e62c25d8b85fd745d4e9ca7b7e6d36bfe095dfe5c4db017d4e785d110f3758f5938dad6f1a1b009267fd7e82cb7212e93e1aea237bab7
+ depends = lib32-zlib
+ depends = lib32-zstd
+ depends = libarchive=3.5.2
+ source = http://libarchive.org/downloads/libarchive-3.5.2.tar.gz
+ sha512sums = 2003ec9b24086373451bd7317bdab86d81627f087c14a6f7df1a92e131a216749f9aa352504c3d04dc82b62078b59aeea5aad5543b7e6c1c21fcafa2955d3762
pkgname = lib32-libarchive
-
diff --git a/PKGBUILD b/PKGBUILD
index 0cbdf890dc99..a9583e886fb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,15 @@
_pkgname=libarchive
pkgname=lib32-${_pkgname}
-pkgver=3.3.3
+pkgver=3.5.2
pkgrel=1
pkgdesc="library that can create and read several streaming archive formats (32 bit)"
arch=('x86_64')
url="http://libarchive.org"
license=('BSD')
-depends=('lib32-acl' 'lib32-bzip2' 'lib32-expat' 'lib32-lzo' 'lib32-openssl' 'lib32-xz' "${_pkgname}")
-makedepends=('gcc-multilib' 'lib32-zlib')
+depends=('lib32-acl' 'lib32-bzip2' 'lib32-expat' 'lib32-lz4' 'lib32-openssl' 'lib32-xz' 'lib32-zlib' 'lib32-zstd' "${_pkgname}=${pkgver}")
source=("http://libarchive.org/downloads/${_pkgname}-${pkgver}.tar.gz")
-sha512sums=('9d12b47d6976efa9f98e62c25d8b85fd745d4e9ca7b7e6d36bfe095dfe5c4db017d4e785d110f3758f5938dad6f1a1b009267fd7e82cb7212e93e1aea237bab7')
+sha512sums=('2003ec9b24086373451bd7317bdab86d81627f087c14a6f7df1a92e131a216749f9aa352504c3d04dc82b62078b59aeea5aad5543b7e6c1c21fcafa2955d3762')
build() {
export CC="gcc -m32"
@@ -20,11 +19,22 @@ build() {
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
cd "${_pkgname}-${pkgver}"
- ./configure --prefix=/usr --without-xml2 --libdir=/usr/lib32 \
- --without-nettle --libexecdir="/usr/lib32/${_pkgname}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --without-xml2 \
+ --without-nettle \
+ --disable-static \
+ --libexecdir="/usr/lib32/${_pkgname}"
+
make
}
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
package() {
cd "${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install