summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeniy Alekseev2016-07-04 13:22:05 +0300
committerEvgeniy Alekseev2016-07-04 13:22:05 +0300
commit8e13596ae4ac4dd4786b6df073db45d0964e1d5b (patch)
tree1025c5b65c9b3a4d6124b93dd6a392071cce913e
parent43b87730280de913582aff78e30bc79feea40d21 (diff)
downloadaur-8e13596ae4ac4dd4786b6df073db45d0964e1d5b.tar.gz
version bump
-rw-r--r--.SRCINFO12
-rw-r--r--0001-mtree-fix-line-filename-length-calculation.patch28
-rw-r--r--PKGBUILD18
3 files changed, 10 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ca61422d734..dea88f29ef48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Jul 4 10:21:53 UTC 2016
pkgbase = lib32-libarchive
pkgdesc = library that can create and read several streaming archive formats (32 bit)
- pkgver = 3.1.2
- pkgrel = 2
+ pkgver = 3.2.1
+ pkgrel = 1
url = http://libarchive.org
arch = x86_64
license = BSD
@@ -14,10 +16,8 @@ pkgbase = lib32-libarchive
depends = lib32-openssl
depends = lib32-xz
depends = libarchive
- source = http://libarchive.org/downloads/libarchive-3.1.2.tar.gz
- source = 0001-mtree-fix-line-filename-length-calculation.patch
- md5sums = efad5a503f66329bb9d2f4308b5de98a
- md5sums = 9727baf88b928417d5d1269891b1209a
+ source = http://libarchive.org/downloads/libarchive-3.2.1.tar.gz
+ md5sums = afa257047d1941a565216edbf0171e72
pkgname = lib32-libarchive
diff --git a/0001-mtree-fix-line-filename-length-calculation.patch b/0001-mtree-fix-line-filename-length-calculation.patch
deleted file mode 100644
index 2299f5fba37e..000000000000
--- a/0001-mtree-fix-line-filename-length-calculation.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From e65bf287f0133426b26611fe3e80b51267987106 Mon Sep 17 00:00:00 2001
-From: Dave Reisner <dreisner@archlinux.org>
-Date: Thu, 21 Feb 2013 19:01:06 -0500
-Subject: [PATCH] mtree: fix line filename length calculation. Fixes #301.
- Signed-off-by: Andres Mejia <amejia004@gmail.com>
-
----
- libarchive/archive_write_set_format_mtree.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/libarchive/archive_write_set_format_mtree.c b/libarchive/archive_write_set_format_mtree.c
-index 9c0613c..f37f723 100644
---- a/libarchive/archive_write_set_format_mtree.c
-+++ b/libarchive/archive_write_set_format_mtree.c
-@@ -1855,9 +1855,9 @@ mtree_entry_setup_filenames(struct archive_write *a, struct mtree_entry *file,
- return (ret);
- }
-
-- /* Make a basename from dirname and slash */
-+ /* Make a basename from file->parentdir.s and slash */
- *slash = '\0';
-- file->parentdir.length = slash - dirname;
-+ file->parentdir.length = slash - file->parentdir.s;
- archive_strcpy(&(file->basename), slash + 1);
- return (ret);
- }
---
-1.8.1.4
diff --git a/PKGBUILD b/PKGBUILD
index 26359c8f9036..aefd54e4849e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,16 @@
_pkgname=libarchive
pkgname=lib32-${_pkgname}
-pkgver=3.1.2
-pkgrel=2
+pkgver=3.2.1
+pkgrel=1
pkgdesc="library that can create and read several streaming archive formats (32 bit)"
arch=('x86_64')
url="http://libarchive.org"
license=('BSD')
depends=('lib32-acl' 'lib32-bzip2' 'lib32-expat' 'lib32-lzo' 'lib32-openssl' 'lib32-xz' "${_pkgname}")
makedepends=('gcc-multilib' 'lib32-zlib')
-source=("http://libarchive.org/downloads/${_pkgname}-${pkgver}.tar.gz"
- '0001-mtree-fix-line-filename-length-calculation.patch')
-md5sums=('efad5a503f66329bb9d2f4308b5de98a'
- '9727baf88b928417d5d1269891b1209a')
-
-prepare() {
- cd "${_pkgname}-${pkgver}"
-
- # https://code.google.com/p/libarchive/issues/detail?id=301
- # upstream commit e65bf287f0133426b26611fe3e80b51267987106
- patch -Np1 -i "${srcdir}/0001-mtree-fix-line-filename-length-calculation.patch"
-}
+source=("http://libarchive.org/downloads/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('afa257047d1941a565216edbf0171e72')
build() {
export CC="gcc -m32"