summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavi da Silva Böger2015-08-09 21:09:20 -0300
committerDavi da Silva Böger2015-08-09 21:09:20 -0300
commit628444b9b6514854ad970cf2e2bfc93c11b7db06 (patch)
treea2be125dfc9cdc7e168ef3a1c27a92a24cedc06b
downloadaur-628444b9b6514854ad970cf2e2bfc93c11b7db06.tar.gz
First commit to AUR4 + update to 1.9.4
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE41
-rw-r--r--PKGBUILD25
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5fe49bed4fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-libaudio2
+ pkgdesc = A package that installs libaudio.so.2
+ pkgver = 1.9.4
+ pkgrel = 1
+ url = http://www.radscan.com/nas.html
+ arch = x86_64
+ groups = lib32
+ license = custom
+ makedepends = pkgextract
+ depends = lib32-libxt
+ source = http://security.ubuntu.com/ubuntu/pool/main/n/nas/libaudio2_1.9.4-3_i386.deb
+ source = LICENSE
+ sha512sums = 9918915d36fd181dccfd8416d31df744991f880e1ae7aa7659a5de49bfa873879063361d002eaf86e5c62aff350a5451553415129eb680f6ae3a557aa706958a
+ sha512sums = 26ca385b79639e7f834531bb7bb3694e8d43b814ddd8f5112039a51bef56d284ecca42700707cd66a8a699a40cb854ffbcf7e120cec83120811c1d74d65ecfb3
+
+pkgname = lib32-libaudio2
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..176925b32668
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,41 @@
+This is the Debian GNU/Linux prepackaged version of NAS, the Network
+Audio System. The Network Audio System was written by Jim Fulton,
+Greg Renda, and Dave Lemke at Network Computing Devices, Inc. and is
+now maintained by Jon Trulson and the NAS development group,
+contactable on the nas mailing list. See
+
+ http://radscan.com/nas.html
+
+for more information.
+
+This package was put together by Steve McIntyre <93sam@debian.org>,
+using sources from:
+
+ http://downloads.sourceforge.net/nas/nas-1.9.1.src.tar.gz
+
+along with various patches from the nas mailing list and Debian changes.
+
+-----------------------------------------------------------------------------
+
+ Copyright 1995 Network Computing Devices, Inc.
+
+ Permission to use, copy, modify, distribute, and sell this software and
+ its documentation for any purpose is hereby granted without fee, provided
+ that the above copyright notice appear in all copies and that both that
+ copyright notice and this permission notice appear in supporting
+ documentation, and that the name Network Computing Devices, Inc. not be
+ used in advertising or publicity pertaining to distribution of this
+ software without specific, written prior permission.
+
+ THIS SOFTWARE IS PROVIDED `AS-IS'. NETWORK COMPUTING DEVICES, INC.,
+ DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING WITHOUT
+ LIMITATION ALL IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+ PARTICULAR PURPOSE, OR NONINFRINGEMENT. IN NO EVENT SHALL NETWORK
+ COMPUTING DEVICES, INC., BE LIABLE FOR ANY DAMAGES WHATSOEVER, INCLUDING
+ SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES, INCLUDING LOSS OF USE, DATA,
+ OR PROFITS, EVEN IF ADVISED OF THE POSSIBILITY THEREOF, AND REGARDLESS OF
+ WHETHER IN AN ACTION IN CONTRACT, TORT OR NEGLIGENCE, ARISING OUT OF OR IN
+ CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+Translation: You can do whatever you want with this software!
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dc454ecfd7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Davi da Silva Böger <dsboger@gmail.com>
+# Contributor: q3k <q3k AT q3k DOT org>
+
+pkgname=lib32-libaudio2
+pkgver=1.9.4
+_pkgrel32=3
+pkgrel=1
+pkgdesc="A package that installs libaudio.so.2"
+arch=('x86_64')
+url="http://www.radscan.com/nas.html"
+license=('custom')
+groups=('lib32')
+depends=('lib32-libxt')
+makedepends=('pkgextract')
+source=("http://security.ubuntu.com/ubuntu/pool/main/n/nas/libaudio2_${pkgver}-${_pkgrel32}_i386.deb" "LICENSE")
+
+package() {
+ bsdtar -xf data.tar.xz
+ mkdir -p ${pkgdir}/usr/lib32
+ cp -R ${srcdir}/usr/lib/i386-linux-gnu/libaudio* $pkgdir/usr/lib32/
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ install -D -m644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+sha512sums=('9918915d36fd181dccfd8416d31df744991f880e1ae7aa7659a5de49bfa873879063361d002eaf86e5c62aff350a5451553415129eb680f6ae3a557aa706958a' '26ca385b79639e7f834531bb7bb3694e8d43b814ddd8f5112039a51bef56d284ecca42700707cd66a8a699a40cb854ffbcf7e120cec83120811c1d74d65ecfb3')