summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2015-06-29 18:00:54 +0200
committerJohannes Dewender2015-06-29 18:00:54 +0200
commit0ffebb96156e3b5149057388387556b437459149 (patch)
tree32e58f743efb54683522adf366cda75b38e4a903
parent3638b7fb3aac3ca3614249bdd2af9abdd60a57c7 (diff)
downloadaur-0ffebb96156e3b5149057388387556b437459149.tar.gz
fix dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8afc9fdfba58..7a04ef13c2fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = lib32-libbluray
- pkgdesc = Library to access Blu-Ray disks for video playback (32bit)
+ pkgdesc = Library to access Blu-Ray disks for video playback (32 bit)
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.videolan.org/developers/libbluray.html
arch = x86_64
license = LGPL2.1
makedepends = gcc-multilib
+ depends = libbluray
depends = lib32-libxml2
+ depends = lib32-freetype2
depends = lib32-fontconfig
- options = !libtool
source = ftp://ftp.videolan.org/pub/videolan/libbluray/0.7.0/libbluray-0.7.0.tar.bz2
sha512sums = 2bf73398003e5a6b12ffdf44ec5716c18da4a176328b4eac52adb3337d09fcb4e5b553362cb67d70506fb0b2cd60e2e59ccc398104630554f41f0b095fc4703f
diff --git a/PKGBUILD b/PKGBUILD
index 7b577e60a5ed..80d8001e68c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer: josephgbr <rafael.f.f1@gmail.com>
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+# Contributor: josephgbr <rafael.f.f1@gmail.com>
_pkgbase=libbluray
pkgname=lib32-${_pkgbase}
pkgver=0.7.0
-pkgrel=1
-pkgdesc="Library to access Blu-Ray disks for video playback (32bit)"
+pkgrel=2
+pkgdesc="Library to access Blu-Ray disks for video playback (32 bit)"
arch=('x86_64')
url="http://www.videolan.org/developers/libbluray.html"
license=('LGPL2.1')
-depends=('lib32-libxml2' 'lib32-fontconfig')
+depends=("$_pkgbase" 'lib32-libxml2' 'lib32-freetype2' 'lib32-fontconfig')
makedepends=('gcc-multilib')
-options=(!libtool)
source=(ftp://ftp.videolan.org/pub/videolan/$_pkgbase/$pkgver/$_pkgbase-$pkgver.tar.bz2)
sha512sums=('2bf73398003e5a6b12ffdf44ec5716c18da4a176328b4eac52adb3337d09fcb4e5b553362cb67d70506fb0b2cd60e2e59ccc398104630554f41f0b095fc4703f')
@@ -19,8 +19,7 @@ build() {
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
cd $_pkgbase-$pkgver
- ./configure --prefix=/usr \
- --libdir=/usr/lib32 \
+ ./configure --prefix=/usr --libdir=/usr/lib32 \
--disable-doxygen-doc
make
}