diff options
author | somebody1234 | 2021-06-10 15:19:43 +1000 |
---|---|---|
committer | somebody1234 | 2021-06-10 15:19:43 +1000 |
commit | a01e6f328a1c01d7dfc803a93442c384dc455f6b (patch) | |
tree | db0f4116191c18a6cfbb37a73a532064ffcc0466 | |
parent | 72e1eaa2fb623e45bbaa7f85d4fee7a73aa48d4d (diff) | |
download | aur-a01e6f328a1c01d7dfc803a93442c384dc455f6b.tar.gz |
fix: printf
-rw-r--r-- | .SRCINFO | 7 | ||||
-rw-r--r-- | PKGBUILD | 20 | ||||
-rw-r--r-- | printf.patch | 12 |
3 files changed, 32 insertions, 7 deletions
@@ -1,7 +1,7 @@ pkgbase = lib32-libbs2b pkgdesc = Bauer stereophonic-to-binaural DSP effect library pkgver = 3.1.0 - pkgrel = 3 + pkgrel = 4 url = http://bs2b.sourceforge.net arch = i686 arch = x86_64 @@ -9,7 +9,8 @@ pkgbase = lib32-libbs2b depends = lib32-libsndfile depends = libbs2b source = https://cfhcable.dl.sourceforge.net/project/bs2b/libbs2b/3.1.0/libbs2b-3.1.0.tar.gz - sha1sums = a71318211611a00bd3d595b0830d2188938ff89d + source = printf.patch + sha512sums = SKIP + sha512sums = SKIP pkgname = lib32-libbs2b - @@ -1,16 +1,28 @@ -# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com> +# Maintainer: E-Hern Lee <ehern.lee@gmail.com> +# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com> # Contributor: Panagiotis Papadopoulos pano_90 AT gmx DOT net + pkgname=lib32-libbs2b _pkgname=libbs2b pkgver=3.1.0 -pkgrel=3 +pkgrel=4 pkgdesc="Bauer stereophonic-to-binaural DSP effect library" arch=('i686' 'x86_64') url='http://bs2b.sourceforge.net' license=('GPL') depends=('lib32-libsndfile' 'libbs2b') -source=(https://cfhcable.dl.sourceforge.net/project/bs2b/$_pkgname/$pkgver/$_pkgname-$pkgver.tar.gz) -sha1sums=('a71318211611a00bd3d595b0830d2188938ff89d') +source=( + https://cfhcable.dl.sourceforge.net/project/bs2b/$_pkgname/$pkgver/$_pkgname-$pkgver.tar.gz + printf.patch +) +sha512sums=( + 'SKIP' + 'SKIP' +) + +prepare() { + patch --forward --strip=1 --input="${srcdir}/printf.patch" +} build() { cd "${_pkgname}-${pkgver}" diff --git a/printf.patch b/printf.patch new file mode 100644 index 000000000000..90bb248b139c --- /dev/null +++ b/printf.patch @@ -0,0 +1,12 @@ +diff --unified --recursive --text libbs2b-3.1.0/src/bs2bconvert.c libbs2b-3.1.0.new/src/bs2bconvert.c +--- src/libbs2b-3.1.0/src/bs2bconvert.c 2009-06-05 04:01:15.000000000 +1000 ++++ src/libbs2b-3.1.0.new/src/bs2bconvert.c 2021-06-10 15:11:29.809380636 +1000 +@@ -153,7 +153,7 @@ + if( ( infile = sf_open( infilename, SFM_READ, &sfinfo ) ) == NULL ) + { + printf( "Not able to open input file %s.\n", infilename ); +- printf( sf_strerror( NULL ) ); ++ printf( "%s\n", sf_strerror( NULL ) ); + return 1; + } + |