summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-12 16:46:37 -0500
committerVincent Grande2021-01-12 16:46:37 -0500
commitc13b11afa4101bd596c6df04a5d93da0ba2044fb (patch)
treec0198f36bf2ff5aa59537130d008d843d4a5c992
parent957532e653b2774faff15721bb3b1ee0f8be62f5 (diff)
downloadaur-c13b11afa4101bd596c6df04a5d93da0ba2044fb.tar.gz
pkgver fix
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29b0d6a52f4f..ce3beedf2528 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Dan Beste <dan.ray.beste+aur@gmail.com>
# Contributor: David Runge <dvzrv@archlinux.org>
# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Hugo Doria <hugo@archlinux.org>
@@ -21,9 +22,17 @@ b2sums=('SKIP'
'6f50d5a03c3532e6e50506cd878b1c9ca5cee5f1758f9318d4cb5d1e319cbe5f31210ba46a81b1af30730e2329aed7921c11f1a468a596a3f210972ca0da9d64')
#validpgpkeys=('38A644698C69787344E954CE29EE848AE2CCF3F4') # Andrew G. Morgan <morgan@kernel.org>
+_commit() {
+# Convert HEAD into a shortened commit id:
+ git rev-parse --short HEAD
+}
+
pkgver() {
cd libcap
- git describe --tags | sed 's/-/+/g'
+
+# Suggestions for improvement welcome!
+ printf '%s.r%s.%s' \
+ "$(_commit)"
}
prepare() {