summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitalii Kuzhdin2025-04-08 21:54:56 +0200
committerVitalii Kuzhdin2025-04-08 21:54:56 +0200
commit8ded30752efc2ff0d5f07e3a1173df2d2a9656e2 (patch)
tree273ea0ee50baf79eb08f53449a762397d4ef97ca
parent137abdbecea7ca1b70e56dfe32915368cab95710 (diff)
downloadaur-8ded30752efc2ff0d5f07e3a1173df2d2a9656e2.tar.gz
Initial build (2.3.0)
-rw-r--r--.SRCINFO18
-rw-r--r--.directory6
-rw-r--r--.gitignore5
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD79
5 files changed, 66 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acba3d9d9646..379fba978b93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Sun May 27 13:03:55 UTC 2018
pkgbase = lib32-libcue
- pkgdesc = Parses so-called cue sheets and handles the parsed data (lib32)
- pkgver = 2.2.1
+ pkgdesc = Parses so-called cue sheets and handles the parsed data (32-bit)
+ pkgver = 2.3.0
pkgrel = 1
- url = http://github.com/lipnitsk/libcue/
+ url = https://github.com/lipnitsk/libcue
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = cmake
+ makedepends = lib32-gcc-libs
depends = lib32-glibc
- depends = libcue
- source = libcue-2.2.1.tar.gz::https://github.com/lipnitsk/libcue/archive/v2.2.1.tar.gz
- md5sums = 1dfe65751c3817c76a107bd5a0d924a3
+ depends = libcue>=2.3.0
+ source = libcue-2.3.0.tar.gz::https://github.com/lipnitsk/libcue/archive/refs/tags/v2.3.0.tar.gz
+ sha512sums = fe2c39cc9794ac36c0706405e0432bab23228d343ba4e3395220d5b2a2ebf8b3c97e71d76a628f9144977c0dd56636f78d0c2d1f9f2b0d4068a837a258f035b6
pkgname = lib32-libcue
-
diff --git a/.directory b/.directory
deleted file mode 100644
index 167078390cca..000000000000
--- a/.directory
+++ /dev/null
@@ -1,6 +0,0 @@
-[Dolphin]
-Timestamp=2018,5,27,15,54,28
-Version=4
-
-[Settings]
-HiddenFilesShown=true
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218cc907c9ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!.nvchecker.toml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..7084c7976e18
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[lib32-libcue]
+source = "archpkg"
+archpkg = "libcue"
+strip_release = true
diff --git a/PKGBUILD b/PKGBUILD
index 57b16e6e204a..8fe2c3a6089f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,65 @@
-# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Maintainer: Vitalii Kuzhdin <vitaliikuzhdin@gmail.com>
+# Contributor: GordonGR <ntheo1979@gmail.com>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: said <atvordhosbn[at]gmail[dot]com>
-pkgname=lib32-libcue
-_pkgname=libcue
-pkgver=2.2.1
+_name="libcue"
+pkgname="lib32-${_name}"
+pkgver=2.3.0
pkgrel=1
-pkgdesc='Parses so-called cue sheets and handles the parsed data (lib32)'
-url='http://github.com/lipnitsk/libcue/'
+pkgdesc="Parses so-called cue sheets and handles the parsed data (32-bit)"
+url="https://github.com/lipnitsk/${_name}"
arch=('x86_64')
-license=('GPL2')
-source=("${_pkgname}-$pkgver.tar.gz::https://github.com/lipnitsk/libcue/archive/v$pkgver.tar.gz")
-depends=('lib32-glibc' 'libcue')
-makedepends=('cmake')
-md5sums=('1dfe65751c3817c76a107bd5a0d924a3')
+license=('GPL-2.0-only')
+depends=('lib32-glibc' "${_name}>=${pkgver}")
+makedepends=('cmake' 'lib32-gcc-libs')
+_pkgsrc="${_name}-${pkgver}"
+source=("${_pkgsrc}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('fe2c39cc9794ac36c0706405e0432bab23228d343ba4e3395220d5b2a2ebf8b3c97e71d76a628f9144977c0dd56636f78d0c2d1f9f2b0d4068a837a258f035b6')
build() {
-cd ${_pkgname}-${pkgver}
+ export CFLAGS+=" -m32"
+ export CXXFLAGS+=" -m32"
+ export LDFLAGS+=" -m32"
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ local cmake_options=(
+ -G 'Unix Makefiles'
+ -B "${_pkgsrc}/build"
+ -S "${_pkgsrc}"
+ -DCMAKE_BUILD_TYPE:STRING='None'
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr'
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib32
+ -DCMAKE_POLICY_VERSION_MINIMUM=3.5
+ -DBUILD_SHARED_LIBS=ON
+ -Wno-dev
+ )
-export CC="gcc -m32"
-export CXX="g++ -m32"
-export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ cd "${srcdir}"
+ cmake "${cmake_options[@]}"
+ cmake --build "${_pkgsrc}/build"
+}
-cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib32 \
- -DBUILD_SHARED_LIBS=ON . \
- -DCC="gcc -m32" \
- -DCXX="g++ -m32" \
- -DPKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+check() {
+ local excluded_tests=""
+ local ctest_flags=(
+ --test-dir "${_pkgsrc}/build"
+ --output-on-failure
+ --parallel $(nproc)
+ --exclude-regex "${excluded_tests}"
+ )
-make
+ cd "${srcdir}"
+ ctest "${ctest_flags[@]}"
}
package() {
-cd ${_pkgname}-${pkgver}
-make DESTDIR="${pkgdir}" install
+ cd "${srcdir}"
+ DESTDIR="${pkgdir}" cmake --install "${_pkgsrc}/build"
-cd "$pkgdir/usr"
-rm -rf {bin,include,share/imlib2}/
-#mv lib/ lib32/
+ cd "${pkgdir}/usr"
+ rm -rf "bin" "include" "share"
-cd "${pkgdir}/usr/lib32/pkgconfig"
-sed -i 's|includedir=${prefix}/include|includedir=${prefix}/include/libcue/|' libcue.pc
-sed -i 's|libdir=${prefix}/lib|libdir=${prefix}/lib32|' libcue.pc
+#cd "${pkgdir}/usr/lib32/pkgconfig"
+#sed -i 's|includedir=${prefix}/include|includedir=${prefix}/include/libcue/|' libcue.pc
+#sed -i 's|libdir=${prefix}/lib|libdir=${prefix}/lib32|' libcue.pc
}