summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2016-04-17 20:46:42 +0300
committerGordonGR2016-04-17 20:46:42 +0300
commitd45256b244fb1628d8c28cd37768619cea9f1c14 (patch)
tree16fda367164aeccf655f1d459fdc0fbca6c49cf8
downloadaur-d45256b244fb1628d8c28cd37768619cea9f1c14.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae2c970445b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Apr 17 17:46:28 UTC 2016
+pkgbase = lib32-libcue
+ pkgdesc = Parses so-called cue sheets and handles the parsed data (lib32)
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = http://github.com/lipnitsk/libcue/
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = lib32-glibc
+ depends = libcue
+ source = libcue-2.1.0.tar.gz::https://github.com/lipnitsk/libcue/archive/v2.1.0.tar.gz
+ md5sums = 0fff773e95175df349329ea34bc775cf
+
+pkgname = lib32-libcue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1778c711a39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: said <atvordhosbn[at]gmail[dot]com>
+
+pkgname=lib32-libcue
+_pkgname=libcue
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='Parses so-called cue sheets and handles the parsed data (lib32)'
+url='http://github.com/lipnitsk/libcue/'
+arch=('x86_64')
+license=('GPL2')
+source=("${_pkgname}-$pkgver.tar.gz::https://github.com/lipnitsk/libcue/archive/v$pkgver.tar.gz")
+depends=('lib32-glibc' 'libcue')
+makedepends=('cmake')
+md5sums=('0fff773e95175df349329ea34bc775cf')
+
+
+build() {
+cd ${_pkgname}-${pkgver}
+
+export CC="gcc -m32"
+export CXX="g++ -m32"
+export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib32 \
+ -DCC="gcc -m32" \
+ -DCXX="g++ -m32" \
+ -DPKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+make
+}
+
+package() {
+cd ${_pkgname}-${pkgver}
+make DESTDIR="${pkgdir}" install
+
+cd "$pkgdir/usr"
+rm -rf {bin,include,share/imlib2}/
+mv lib/ lib32/
+
+cd "${pkgdir}/usr/lib32/pkgconfig"
+sed -i 's|includedir=${prefix}/include|includedir=${prefix}/include/libcue/|' libcue.pc
+sed -i 's|libdir=${prefix}/lib|libdir=${prefix}/lib32|' libcue.pc
+}