summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-22 00:42:22 -0500
committerVincent Grande2020-12-22 00:42:22 -0500
commit79898af61f125fac5c711684b7fa0437be7c37a9 (patch)
tree8fd2030bdf54759e68d440b2f17d0750e846b14c
downloadaur-79898af61f125fac5c711684b7fa0437be7c37a9.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b83aa22a02e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib32-libcups-nosystemd-minimal-git
+ pkgdesc = The CUPS Printing System - client libraries (32-bit)
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = https://www.cups.org/
+ arch = x86_64
+ license = Apache
+ license = custom
+ depends = lib32-krb5
+ depends = lib32-libtiff
+ depends = lib32-libpng
+ depends = lib32-gnutls
+ optdepends = libcups: 64bit support
+ provides = lib32-libcups
+ conflicts = lib32-libcups
+ source = git://github.com/apple/cups.git
+ sha256sums = SKIP
+
+pkgname = lib32-libcups-nosystemd-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd999d1fa5f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=lib32-libcups-nosystemd-minimal-git
+pkgver=2.3.3
+pkgrel=1
+pkgdesc="The CUPS Printing System - client libraries (32-bit)"
+arch=('x86_64')
+license=('Apache' 'custom')
+url="https://www.cups.org/"
+depends=(lib32-krb5 lib32-libtiff lib32-libpng lib32-gnutls)
+optdepends=('libcups: 64bit support')
+provides=(lib32-libcups)
+conflicts=(lib32-libcups)
+source=(git://github.com/apple/cups.git)
+sha256sums=('SKIP')
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd cups
+
+ aclocal -I config-scripts
+ autoconf -I config-scripts
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-libpaper --disable-ldap --disable-raw-printing --disable-gssapi --disable-dbus \
+ --disable-page-logging --disable-upstart --disable-launchd --disable-mallinfo --without-snmp-address --enable-ssl=yes --enable-threads --enable-libusb=no \
+ --disable-systemd --without-systemd --disable-debug --disable-debug-guards --disable-debug-printfs --disable-webif --disable-browsing --disable-avahi --disable-dnssd \
+ --with-optim="$CFLAGS" --libdir=/usr/lib32
+ make libs
+}
+
+package() {
+ cd cups
+ make BUILDROOT="${pkgdir}" install-libs
+ rm -rf "$pkgdir/usr/lib"
+
+# add license + exception
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,NOTICE}
+}
+