summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2019-03-28 22:28:08 -0300
committerRodrigo Bezerra2019-03-28 22:28:08 -0300
commitde026a150ced9d6c4a7fe8103b0783493fd60d3a (patch)
tree5e1012c03fa218fbf33397de976d387ef0216a59
parenta10b2d8642064f07360644004f37ce7df33b378a (diff)
downloadaur-de026a150ced9d6c4a7fe8103b0783493fd60d3a.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD55
2 files changed, 35 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7966172610fc..b0f06b87c026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Feb 17 17:46:42 UTC 2018
pkgbase = lib32-libdvdnav
pkgdesc = The library for xine-dvdnav plugin (32 bit)
pkgver = 6.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.videolan.org/developers/libdvdnav.html
arch = x86_64
license = GPL
@@ -11,7 +9,7 @@ pkgbase = lib32-libdvdnav
depends = lib32-libdvdread
depends = libdvdnav
source = git+https://code.videolan.org/videolan/libdvdnav.git#commit=dcb9109e45ccd304ec82a7c7bf46cca63620adf9
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = lib32-libdvdnav
diff --git a/PKGBUILD b/PKGBUILD
index 4cb42b1cb834..719e74b1fb8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,53 @@
+# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
+# Contributor: GordonGR <ntheo1979@gmail.com>
# Contributor: josephgbr <rafael.f.f1@gmail.com>
-# Maintainer: GordonGR <ntheo1979@gmail.com>
-_pkgname=libdvdnav
-pkgname=lib32-${_pkgname}
+_basename=libdvdnav
+pkgname=lib32-libdvdnav
pkgver=6.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="The library for xine-dvdnav plugin (32 bit)"
-arch=('x86_64')
-license=('GPL')
+arch=(x86_64)
+license=(GPL)
url="https://www.videolan.org/developers/libdvdnav.html"
-depends=('lib32-libdvdread' "${_pkgname}")
+depends=(lib32-libdvdread libdvdnav)
makedepends=('git')
_commit=dcb9109e45ccd304ec82a7c7bf46cca63620adf9 # tags/6.0.0^0
source=("git+https://code.videolan.org/videolan/libdvdnav.git#commit=$_commit")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
-cd ${_pkgname}
-git describe --tags | sed -e 's/-/+/g'
+ cd "${_basename}"
+
+ git describe --tags | sed -e 's/-/+/g'
}
+
prepare() {
-cd "${_pkgname}"
-autoreconf -fi
+ cd "${_basename}"
+
+ autoreconf -fi
}
build() {
-export CC='gcc -m32'
-export CXX='g++ -m32'
-export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-
-cd "${_pkgname}"
-./configure --prefix=/usr --libdir=/usr/lib32
-make
+ cd "${_basename}"
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure \
+ --build=i686-pc-linux-gnu \
+ --prefix=/usr \
+ --libdir=/usr/lib32
+
+ make
}
package() {
-cd "${_pkgname}"
-make DESTDIR="${pkgdir}" install
-rm -rf "${pkgdir}/usr"/{bin,include,share}
+ cd "${_basename}"
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}/usr"/{include,share}
}