summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2015-07-16 04:26:19 -0700
committerLlewelyn Trahaearn2015-07-16 04:26:19 -0700
commit6a39141db5d823c5780f064fd28dff6e05d573ca (patch)
tree2a82243be9820a20d961c052676d3211651b97dd
parentb1712d591aba637c856a4fdc599b1227e1d5bc2e (diff)
downloadaur-6a39141db5d823c5780f064fd28dff6e05d573ca.tar.gz
Package tuning.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11c73bd79e16..2dff5aef68fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-libexif
pkgdesc = A library to parse an EXIF file and read the data from those tags (32-bit)
pkgver = 0.6.21
- pkgrel = 2
+ pkgrel = 3
url = http://sourceforge.net/projects/libexif
arch = x86_64
license = LGPL
diff --git a/PKGBUILD b/PKGBUILD
index 59ccfb2eba48..b98e471a2f9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
# Contributor: josephgbr <rafael.f.f1 at gmail dot com>
+
_pkgbase=libexif
pkgname=lib32-${_pkgbase}
pkgver=0.6.21
-pkgrel=2
+pkgrel=3
pkgdesc="A library to parse an EXIF file and read the data from those tags (32-bit)"
arch=('x86_64')
license=('LGPL')
@@ -15,9 +16,11 @@ source=(http://downloads.sf.net/sourceforge/${_pkgbase}/${_pkgbase}-${pkgver}.ta
sha512sums=('4e0fe2abe85d1c95b41cb3abe1f6333dc3a9eb69dba106a674a78d74a4d5b9c5a19647118fa1cc2d72b98a29853394f1519eda9e2889eb28d3be26b21c7cfc35')
build() {
- export CC='gcc -m32'
-
cd "${srcdir}/${_pkgbase}-${pkgver}"
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export LDFLAGS='-m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
./configure --prefix=/usr --libdir=/usr/lib32
make
}
@@ -25,6 +28,5 @@ build() {
package() {
cd "${srcdir}/${_pkgbase}-${pkgver}"
make DESTDIR="${pkgdir}" install
-
- rm -rf ${pkgdir}/usr/{include,share,lib32/*.a}
+ rm -rf "${pkgdir}/usr/"{include,share,lib32/*.a}
}