summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2021-07-16 14:19:26 -0700
committerLlewelyn Trahaearn2021-07-16 14:19:26 -0700
commit8841520cf38af9ac5a7db1b41d4bb394cebaeab1 (patch)
treea457f83c7903647fecb0afafb7393e0ed64e5d26
parent17841151c42a2b2eab37e718452dc2f0df34da7e (diff)
downloadaur-8841520cf38af9ac5a7db1b41d4bb394cebaeab1.tar.gz
Update to 0.6.22
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6b2b09b8943..7acba26b37ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Fri Jan 13 21:40:08 UTC 2017
pkgbase = lib32-libexif
pkgdesc = A library to parse an EXIF file and read the data from those tags (32-bit)
- pkgver = 0.6.21
- pkgrel = 4
- url = http://sourceforge.net/projects/libexif
+ pkgver = 0.6.22
+ pkgrel = 1
+ url = https://github.com/libexif/libexif
arch = x86_64
license = LGPL
makedepends = gcc-multilib
depends = libexif
depends = lib32-glibc
options = !libtool
- source = http://downloads.sf.net/sourceforge/libexif/libexif-0.6.21.tar.bz2
- sha512sums = 4e0fe2abe85d1c95b41cb3abe1f6333dc3a9eb69dba106a674a78d74a4d5b9c5a19647118fa1cc2d72b98a29853394f1519eda9e2889eb28d3be26b21c7cfc35
+ source = https://github.com/libexif/libexif/archive/libexif-0_6_22-release.tar.gz
+ sha512sums = 6c63abe2734c9e83fb04adb00bdd77f687165007c0efd0279df26c101363b990604050c430c7dd73dfa8735dd2fd196334d321bdb114d4869998f21e7bed5b43
pkgname = lib32-libexif
diff --git a/PKGBUILD b/PKGBUILD
index d1bb8080c50e..bd90aa1cdac6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: josephgbr <rafael.f.f1 at gmail dot com>
pkgname=lib32-libexif
-pkgver=0.6.21
-pkgrel=4
+pkgver=0.6.22
+pkgrel=1
pkgdesc="A library to parse an EXIF file and read the data from those tags (32-bit)"
arch=('x86_64')
license=('LGPL')
-url="http://sourceforge.net/projects/libexif"
+url="https://github.com/libexif/libexif"
depends=("${pkgname#lib32-}" 'lib32-glibc')
makedepends=('gcc-multilib')
options=('!libtool')
-source=(http://downloads.sf.net/sourceforge/${pkgname#lib32-}/${pkgname#lib32-}-${pkgver}.tar.bz2)
-sha512sums=('4e0fe2abe85d1c95b41cb3abe1f6333dc3a9eb69dba106a674a78d74a4d5b9c5a19647118fa1cc2d72b98a29853394f1519eda9e2889eb28d3be26b21c7cfc35')
+source=(${url}/archive/${pkgname#lib32-}-${pkgver//./_}-release.tar.gz)
+sha512sums=('6c63abe2734c9e83fb04adb00bdd77f687165007c0efd0279df26c101363b990604050c430c7dd73dfa8735dd2fd196334d321bdb114d4869998f21e7bed5b43')
build() {
# Modify environment to generate 32-bit ELF. Respects flags defined in makepkg.conf
@@ -21,13 +21,14 @@ build() {
export LDFLAGS="-m32 ${LDFLAGS}"
export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig'
- cd "${pkgname#lib32-}-${pkgver}"
+ cd "${pkgname#lib32-}-${pkgname#lib32-}-${pkgver//./_}-release"
+ autoreconf -i
./configure --build=i686-pc-linux-gnu --prefix=/usr --libdir=/usr/lib32
make
}
package() {
- cd "${pkgname#lib32-}-${pkgver}"
+ cd "${pkgname#lib32-}-${pkgname#lib32-}-${pkgver//./_}-release"
make DESTDIR="${pkgdir}" install
rm -rf "${pkgdir}/usr/"{include,share}
}