summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-06-19 16:07:34 -0400
committerAndrew Sun2019-06-19 16:07:34 -0400
commit0426d7a0d0b05f4eb7a716a36ef50f047818b86c (patch)
tree8bdd4313cf3b8ce731dfe9592aad44aa220a4981
parent4b178eb07d23be09086b10aaf631eec4a5048f9e (diff)
downloadaur-0426d7a0d0b05f4eb7a716a36ef50f047818b86c.tar.gz
lib32-libfilezilla: update to 0.17.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fc97f6299d1..3ea34dba8d75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = lib32-libfilezilla
pkgdesc = Small and modern C++ library, offering some basic functionality to build high-performing, platform-independent programs (32-bit)
- pkgver = 0.16.0
+ pkgver = 0.17.0
pkgrel = 1
url = https://lib.filezilla-project.org/
arch = x86_64
license = GPL
checkdepends = lib32-cppunit
makedepends = clang
+ makedepends = gettext
depends = lib32-gcc-libs
depends = lib32-clang
depends = lib32-nettle
+ depends = lib32-gnutls
depends = libfilezilla
- source = https://download.filezilla-project.org/libfilezilla/libfilezilla-0.16.0.tar.bz2
- sha512sums = ea3302ae0c51582d6715fa3dd06d330a2ac820c3229b4dcab4a3470021dba667b6aea1a5b13168d720d7218cc8513e40c97990ed6573d0ea46d76e6ef50c2e6e
+ source = https://download.filezilla-project.org/libfilezilla/libfilezilla-0.17.0.tar.bz2
+ sha512sums = 4bd61a7eacfaf38f6cf0ecf099629febe8a31d7db3fccd3779b73eb9d13823d929b3db09b83e03410867f8bd3e1adf94683ad51c8b4a52fda63e0433d04c6f9f
pkgname = lib32-libfilezilla
diff --git a/PKGBUILD b/PKGBUILD
index f1118db18ebf..f28276aaf00d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_pkgname=libfilezilla
pkgname=lib32-${_pkgname}
-pkgver=0.16.0
+pkgver=0.17.0
pkgrel=1
pkgdesc="Small and modern C++ library, offering some basic functionality to build high-performing, platform-independent programs (32-bit)"
arch=('x86_64')
url="https://lib.filezilla-project.org/"
license=('GPL')
-depends=("lib32-gcc-libs" "lib32-clang" "lib32-nettle" "${_pkgname}")
-makedepends=("clang")
+depends=("lib32-gcc-libs" "lib32-clang" "lib32-nettle" "lib32-gnutls" "${_pkgname}")
+makedepends=("clang" "gettext")
checkdepends=("lib32-cppunit")
source=("https://download.filezilla-project.org/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2")
-sha512sums=('ea3302ae0c51582d6715fa3dd06d330a2ac820c3229b4dcab4a3470021dba667b6aea1a5b13168d720d7218cc8513e40c97990ed6573d0ea46d76e6ef50c2e6e')
+sha512sums=('4bd61a7eacfaf38f6cf0ecf099629febe8a31d7db3fccd3779b73eb9d13823d929b3db09b83e03410867f8bd3e1adf94683ad51c8b4a52fda63e0433d04c6f9f')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"