summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2021-01-26 06:39:59 +0800
committerFelix Yan2021-01-26 06:39:59 +0800
commitdbefe0a9518ab9339f91f6ea25fd5df343b66a9e (patch)
tree832d5ff672f4b36422d35c9672b374df2bad5a2c
downloadaur-dbefe0a9518ab9339f91f6ea25fd5df343b66a9e.tar.gz
Re-upload to AUR
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--libglade-2.0.1-nowarning.patch39
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df561a4d45a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib32-libglade
+ pkgdesc = Allows you to load glade interface files in a program at runtime (32-bit)
+ pkgver = 2.6.4
+ pkgrel = 7
+ url = https://www.gnome.org
+ arch = x86_64
+ license = LGPL
+ makedepends = python2
+ makedepends = pkgconfig
+ makedepends = gcc-multilib
+ depends = lib32-gtk2
+ depends = lib32-libxml2
+ depends = libglade
+ source = https://download.gnome.org/sources/libglade/2.6/libglade-2.6.4.tar.bz2
+ source = libglade-2.0.1-nowarning.patch
+ sha512sums = b725842febaf4c1f0d305a629ae1c61ea2de24dd6f41937e806c078fada2cea483195ef40f5238ce2045e47130c92559e984f677de667b840dd7fff0f8559735
+ sha512sums = 5ab9dfb85938fb7e9ec637a9d68f3db961f3986e1eb9eec0d684af4ce2361c83d6998283b2bd5b4e1bd7950ca456cc3ea7fae567ac52ae391f6c9d5456c6dd2e
+
+pkgname = lib32-libglade
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbbd8deb810a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: TryA <tryagainprod {at} gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+_pkgbasename=libglade
+pkgname=lib32-libglade
+pkgver=2.6.4
+pkgrel=7
+pkgdesc="Allows you to load glade interface files in a program at runtime (32-bit)"
+arch=('x86_64')
+license=('LGPL')
+depends=('lib32-gtk2' 'lib32-libxml2' "${_pkgbasename}")
+makedepends=('python2' 'pkgconfig' 'gcc-multilib')
+source=("https://download.gnome.org/sources/${_pkgbasename}/2.6/${_pkgbasename}-${pkgver}.tar.bz2"
+ 'libglade-2.0.1-nowarning.patch')
+url='https://www.gnome.org'
+sha512sums=('b725842febaf4c1f0d305a629ae1c61ea2de24dd6f41937e806c078fada2cea483195ef40f5238ce2045e47130c92559e984f677de667b840dd7fff0f8559735'
+ '5ab9dfb85938fb7e9ec637a9d68f3db961f3986e1eb9eec0d684af4ce2361c83d6998283b2bd5b4e1bd7950ca456cc3ea7fae567ac52ae391f6c9d5456c6dd2e')
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ patch -Np1 -i "${srcdir}/libglade-2.0.1-nowarning.patch"
+ PYTHON=python2 ./configure --sysconfdir=/etc --prefix=/usr --localstatedir=/var --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf ${pkgdir}/usr/{bin,include,share}
+}
diff --git a/libglade-2.0.1-nowarning.patch b/libglade-2.0.1-nowarning.patch
new file mode 100644
index 000000000000..fd071215fa0a
--- /dev/null
+++ b/libglade-2.0.1-nowarning.patch
@@ -0,0 +1,39 @@
+--- libglade-2.0.1/glade/glade-gtk.c.nowarning 2003-08-29 14:50:10.000000000 -0400
++++ libglade-2.0.1/glade/glade-gtk.c 2003-08-29 14:58:41.000000000 -0400
+@@ -639,9 +639,8 @@
+ if (!strcmp (childinfo->properties[j].name, "label")) {
+ label = childinfo->properties[j].value;
+ break;
+- } else {
+- g_warning ("Unknown CList child property: %s", childinfo->properties[j].name);
+ }
++ /* Ignore all other properties */
+ }
+
+ if (label) {
+@@ -683,6 +682,7 @@
+ char *icon = NULL;
+ gboolean use_stock = FALSE, active = FALSE, new_group = FALSE;
+ gboolean use_underline = FALSE;
++ gboolean sensitive = TRUE;
+ GtkWidget *iconw = NULL;
+ int j;
+
+@@ -708,6 +708,8 @@
+ group_name = value;
+ } else if (!strcmp (name, "new_group")) {
+ new_group = BOOL (value);
++ } else if (!strcmp (name, "sensitive")) {
++ sensitive = BOOL (value);
+ } else if (!strcmp (name, "visible")) {
+ /* ignore for now */
+ } else if (!strcmp (name, "tooltip")) {
+@@ -785,6 +787,8 @@
+ gtk_label_set_use_underline (GTK_LABEL (toolbar_child->label),
+ TRUE);
+ }
++
++ gtk_widget_set_sensitive (child, sensitive);
+
+ glade_xml_set_common_params (xml, child, childinfo->child);
+ } else {