summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2017-07-09 05:27:56 +0900
committerorumin2017-07-09 05:27:56 +0900
commitaa5f1dea47966a5510a1a131617624c5042429ae (patch)
tree4d87e0ba89764b580f7605329e0e91b094a40902
downloadaur-aa5f1dea47966a5510a1a131617624c5042429ae.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD53
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fa2d71076e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lib32-libgphoto2
+ pkgdesc = The core library of gphoto2, designed to allow access to digital camera by external programs. (32-bit)
+ pkgver = 2.5.14+6+g695b55887
+ pkgrel = 1
+ url = http://www.gphoto.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = autoconf-archive
+ makedepends = git
+ depends = lib32-libexif
+ depends = lib32-libjpeg
+ depends = lib32-gd
+ depends = lib32-libltdl
+ depends = lib32-libusb
+ depends = lib32-libxml2
+ depends = libgphoto2
+ source = git+https://github.com/gphoto/libgphoto2#commit=695b558871fb5274d840647f71d42a77cfa7447f
+ validpgpkeys = 7C4AFD61D8AAE7570796A5172209D6902F969C95
+ sha256sums = SKIP
+
+pkgname = lib32-libgphoto2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77ae026bf2cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: orumin <dev at orum.in>
+
+pkgname=lib32-libgphoto2
+_basename=libgphoto2
+pkgver=2.5.14+6+g695b55887
+pkgrel=1
+pkgdesc="The core library of gphoto2, designed to allow access to digital camera by external programs. (32-bit)"
+arch=(x86_64)
+url="http://www.gphoto.org/"
+license=(LGPL)
+depends=(lib32-libexif lib32-libjpeg lib32-gd lib32-libltdl lib32-libusb lib32-libxml2 libgphoto2)
+makedepends=(autoconf-archive git)
+_commit=695b558871fb5274d840647f71d42a77cfa7447f # master
+source=("git+https://github.com/gphoto/libgphoto2#commit=$_commit")
+sha256sums=('SKIP')
+validpgpkeys=('7C4AFD61D8AAE7570796A5172209D6902F969C95') # Marcus Meissner
+
+pkgver() {
+ cd $_basename
+ git describe --tags | sed 's/^libgphoto2-//;s/-release//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd $_basename
+ autoreconf -fvi
+}
+
+build() {
+ cd $_basename
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr --disable-rpath --build=i686-pc-linux-gnu --libdir=/usr/lib32
+
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
+
+ make
+}
+
+package() {
+ cd $_basename
+ make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir"/usr/bin
+ rm -r "$pkgdir"/usr/include
+ rm -r "$pkgdir"/usr/share
+
+ # Remove unused udev helper
+ rm -r "$pkgdir/usr/lib32/udev"
+}
+