summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-06 03:34:45 -0500
committerVincent Grande2021-01-06 03:34:45 -0500
commitf97a70b4b6b97b18cf065a3a63fed714d73e2e52 (patch)
tree20cabf1827d5001c55825a5999745a8abb7fa326
downloadaur-f97a70b4b6b97b18cf065a3a63fed714d73e2e52.tar.gz
initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6938b975887
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-libidn2-git
+ pkgdesc = Free software implementation of IDNA2008, Punycode and TR46
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://www.gnu.org/software/libidn/#libidn2
+ arch = x86_64
+ license = GPL2
+ license = LGPL3
+ makedepends = ruby-ronn
+ depends = libidn2
+ depends = lib32-glibc
+ depends = lib32-libunistring
+ source = git+https://gitlab.com/libidn/libidn2.git
+ sha256sums = SKIP
+
+pkgname = lib32-libidn2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88a0cc5f4f56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Levente Polyak <anthraxx@archlinux.org>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Daurnimator <quae@daurnimator.com>
+
+pkgname=lib32-libidn2-git
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='Free software implementation of IDNA2008, Punycode and TR46'
+url='https://www.gnu.org/software/libidn/#libidn2'
+arch=('x86_64')
+license=('GPL2' 'LGPL3')
+depends=('libidn2' 'lib32-glibc' 'lib32-libunistring')
+makedepends=('ruby-ronn')
+source=("git+https://gitlab.com/libidn/libidn2.git")
+sha256sums=('SKIP')
+#validpgpkeys=('1CB27DBC98614B2D5841646D08302DB6A2670428') # Tim Rühsen <tim.ruehsen@gmx.de>
+
+pkgver() {
+ cd libidn2
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd libidn2
+ autoreconf -fvi
+}
+
+build() {
+ cd libidn2
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib32
+ make
+}
+
+#check() {
+# cd libidn2
+# make check
+#}
+
+package() {
+ cd libidn2
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
+}
+
+# vim: ts=2 sw=2 et: