summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 16:34:32 +0200
committerMattias Andrée2015-06-11 16:34:32 +0200
commit605629158fd36b11b8cfedd0ec65af59dd2eb5b6 (patch)
tree3371e44e0c8c117166c687afd69ea220f3fccd25
downloadaur-605629158fd36b11b8cfedd0ec65af59dd2eb5b6.tar.gz
Initial import, version 0.8
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7414a4eb94d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-libjson
+ pkgdesc = Small C library and small codebase that packs an efficient parser and a configurable printer (32-bit version)
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://projects.snarc.org/libjson/
+ arch = x86_64
+ license = LGPL
+ makedepends = gcc-multilib
+ depends = lib32-glibc
+ depends = libjson
+ options = !libtool
+ options = !makeflags
+ source = http://projects.snarc.org/libjson/download/libjson-0.8.tar.gz
+ md5sums = f8eddc87510d399a2532a9b0d74c2455
+
+pkgname = lib32-libjson
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6cd236b4865
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+_pkgbasename=libjson
+pkgname=lib32-$_pkgbasename
+pkgver='0.8'
+pkgrel='1'
+pkgdesc="Small C library and small codebase that packs an efficient parser and a configurable printer (32-bit version)"
+arch=('x86_64')
+url="http://projects.snarc.org/libjson/"
+license=('LGPL')
+depends=(lib32-glibc $_pkgbasename)
+makedepends=(gcc-multilib)
+options=(!libtool !makeflags)
+source=('http://projects.snarc.org/libjson/download/libjson-0.8.tar.gz')
+md5sums=('f8eddc87510d399a2532a9b0d74c2455')
+
+build() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ sed -i s:/lib:/lib32:g Makefile
+ make CC="gcc -m32" CFLAGS:='-Wall -Os -fPIC'
+}
+
+package() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+
+ make CC="gcc -m32" CFLAGS:='-Wall -Os -fPIC' DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/bin"
+ rm -r "${pkgdir}/usr/include"
+}
+