summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXorg2015-01-23 17:52:56 +0100
committerXorg2015-01-23 17:52:56 +0100
commitcde4e1132db7461f6b2faa248057bee9424d4ee1 (patch)
tree54a58b25e7d4641101c5d7b156577201912bc330
downloadaur-cde4e1132db7461f6b2faa248057bee9424d4ee1.tar.gz
Initial commit for lib32-libkqueue
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2239d04a7354
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lib32-libkqueue
+ pkgdesc = Userspace implementation of the kqueue kernel event notification mechanism found in FreeBSD and other BSD-based (32-bit)
+ pkgver = 2.0.3
+ pkgrel = 2
+ url = https://github.com/mheily/libkqueue
+ arch = x86_64
+ license = BSD
+ makedepends = gcc-multilib
+ depends = lib32-glibc
+ depends = libkqueue
+ options = !libtool
+ source = https://github.com/mheily/libkqueue/releases/download/v2.0.3/libkqueue-2.0.3.tar.gz
+ md5sums = 42d405a26c36f734e2c7d3a936e30abe
+
+pkgname = lib32-libkqueue
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e70601bf495d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: X0rg
+# Contributor: Nicolas QuiƩnot < niQo at aur >
+
+_realname=libkqueue
+pkgname=lib32-$_realname
+pkgver=2.0.3
+pkgrel=2
+pkgdesc="Userspace implementation of the kqueue kernel event notification mechanism found in FreeBSD and other BSD-based (32-bit)"
+url="https://github.com/mheily/libkqueue"
+arch=('x86_64')
+license=('BSD')
+depends=('lib32-glibc' 'libkqueue')
+makedepends=('gcc-multilib')
+options=('!libtool')
+source=("https://github.com/mheily/$_realname/releases/download/v$pkgver/$_realname-$pkgver.tar.gz")
+md5sums=('42d405a26c36f734e2c7d3a936e30abe')
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ msg2 "Run 'configure'..."
+ ./configure --prefix=/usr --libdir=/usr/lib32 --disable-static
+
+ msg2 "Run 'make'..."
+ make
+
+ msg2 "Extract license..."
+ sed -n '/Copyright/,/ OF THIS SOFTWARE./p' "./src/common/kqueue.c" | cut -c 4- > "LICENSE"
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ msg2 "Install license..."
+ install -Dvm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Clean up lib32 package
+ rm -rf "$pkgdir/usr/include" "$pkgdir/usr/share/man"
+}