summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2018-02-24 14:59:07 +0200
committerGordonGR2018-02-24 14:59:07 +0200
commit0f2c3fe2886c7757179efc8b34168d9643aa7323 (patch)
tree4be71763f56079ec59c71acc55a2b283c4a732c4
parent9048903c72c75439633f57eeb8eff744cf4a8109 (diff)
downloadaur-0f2c3fe2886c7757179efc8b34168d9643aa7323.tar.gz
0.6.1-1: Upstream update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15033b031a11..d7066eb253ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Sat Apr 29 11:46:38 UTC 2017
+# Sat Feb 24 12:58:32 UTC 2018
pkgbase = lib32-liblrdf
pkgdesc = A library for the manipulation of RDF file in LADSPA plugins (32 bit)
- pkgver = 0.5.0
- pkgrel = 4
+ pkgver = 0.6.1
+ pkgrel = 1
url = https://github.com/swh/LRDF
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = gcc-multilib
depends = lib32-raptor
depends = liblrdf
- source = liblrdf-0.5.0.tar.gz::https://github.com/swh/LRDF/tarball/0.5.0
- md5sums = 005ea24152620da7f2ee80a78e17f784
+ source = liblrdf-0.6.1.tar.gz::https://github.com/swh/LRDF/archive/v0.6.1.tar.gz
+ md5sums = 8bb0ac7e8fe1a5a90083c89776bd3deb
pkgname = lib32-liblrdf
diff --git a/PKGBUILD b/PKGBUILD
index d42b7eb81d72..14e71b8b46ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,37 @@
_pkgname=liblrdf
pkgname=lib32-${_pkgname}
-pkgver=0.5.0
-pkgrel=4
+pkgver=0.6.1
+pkgrel=1
pkgdesc="A library for the manipulation of RDF file in LADSPA plugins (32 bit)"
arch=('x86_64')
url="https://github.com/swh/LRDF"
depends=('lib32-raptor' "$_pkgname")
makedepends=('gcc-multilib')
-license=('GPL')
-source=(${_pkgname}-${pkgver}.tar.gz::https://github.com/swh/LRDF/tarball/${pkgver})
-md5sums=('005ea24152620da7f2ee80a78e17f784')
+license=('GPL2')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/swh/LRDF/archive/v${pkgver}.tar.gz")
+md5sums=('8bb0ac7e8fe1a5a90083c89776bd3deb')
+
+prepare() {
+mv -v "LRDF-${pkgver}" "${_pkgname}-${pkgver}"
+cd "${_pkgname}-${pkgver}"
+autoreconf -vfi
+sed -e 's,raptor.h,raptor2/raptor.h,' -i lrdf.h
+}
build() {
+cd "${_pkgname}-${pkgver}"
+
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-
-cd swh-LRDF-7ebc032
-sed -i 's#AM_CONFIG_HEADER(config.h)#AC_CONFIG_HEADERS([config.h])#' configure.ac
-autoreconf -vfi
./configure --prefix=/usr --libdir=/usr/lib32
make
}
package() {
-cd swh-LRDF-7ebc032
+cd "${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
rm -rf "${pkgdir}"/usr/{include,share}
}