summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeke Sonxx2016-09-03 21:42:10 -0400
committerZeke Sonxx2016-09-03 21:42:10 -0400
commit6a9d9c23663927844aa1e745bd35e761b04e2f57 (patch)
treede31c44a7c347a95252bf3a722bb37cf44accc19
downloadaur-6a9d9c23663927844aa1e745bd35e761b04e2f57.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD47
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..664cca4d3ac8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-libmumble
+ pkgdesc = A voice chat application similar to TeamSpeak (32-bit overlay library)
+ pkgver = 1.2.16
+ pkgrel = 1
+ url = http://mumble.sourceforge.net/
+ arch = x86_64
+ license = BSD
+ makedepends = boost
+ makedepends = mesa
+ makedepends = gcc-multilib
+ depends = mumble=1.2.16
+ depends = lib32-libgl
+ source = https://github.com/mumble-voip/mumble/releases/download/1.2.16/mumble-1.2.16.tar.gz
+ md5sums = 58e7574af80e36e0b943df0e6a44d6ce
+
+pkgname = lib32-libmumble
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6130c0391d37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/*
+src/*
+*.pkg.*
+
+# mumble source
+mumble*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6550649093e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# shellcheck shell=bash
+# shellcheck disable=SC2034,SC2148,SC2154
+# Maintainer: Zeke Sonxx <zeke@zekesonxx.com>
+# Contributer: Matjaz Mozetic <rationalperseus@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Lauri Niskanen <ape@ape3000.com>
+# Contributor: Sebastian.Salich@gmx.de
+# Contributor: Doc Angelo
+
+# Based both on the community/mumble package and the old lib32-libmumble package.
+# https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/mumble
+# http://pkgbuild.com/git/aur-mirror.git/tree/lib32-libmumble/PKGBUILD
+
+pkgname=lib32-libmumble
+pkgver=1.2.16
+pkgrel=1
+arch=('x86_64')
+pkgdesc="A voice chat application similar to TeamSpeak (32-bit overlay library)"
+license=('BSD')
+depends=("mumble=$pkgver" 'lib32-libgl')
+makedepends=('boost' 'mesa' 'gcc-multilib')
+url="http://mumble.sourceforge.net/"
+source=("https://github.com/mumble-voip/mumble/releases/download/${pkgver}/mumble-${pkgver}.tar.gz")
+md5sums=('58e7574af80e36e0b943df0e6a44d6ce')
+sha512sums=('8624d4db8ae135dae780bd5743f50d3a4740c5b983d18da6a19803e340fbac939204bac81b34d55a114e963b33eddefc292bc3cfea3827431ded5cad5284e565')
+
+build() {
+ cd "$srcdir/mumble-$pkgver/overlay_gl" || exit
+
+ qmake-qt4 overlay_gl.pro QMAKE_CFLAGS+="-m32" QMAKE_LFLAGS+="-m32"
+ make
+}
+
+package() {
+ cd "$srcdir/mumble-$pkgver" || exit
+
+ # lib stuff
+ install -m755 -D "./release/libmumble.so.$pkgver" "$pkgdir/usr/lib32/mumble/libmumble.so.$pkgver"
+ ln -s "libmumble.so.$pkgver" "$pkgdir/usr/lib32/mumble/libmumble.so"
+ ln -s "libmumble.so.$pkgver" "$pkgdir/usr/lib32/mumble/libmumble.so.1"
+ ln -s "libmumble.so.$pkgver" "$pkgdir/usr/lib32/mumble/libmumble.so.1.2"
+
+ # license
+ install -d "$pkgdir/usr/share/licenses"
+ ln -s "/usr/share/licenses/mumble" "$pkgdir/usr/share/licenses/$pkgname"
+}