summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2020-01-31 18:18:48 +0330
committerBehnam Momeni2020-01-31 18:18:48 +0330
commit76121aec4e8c77f5f79b2b177daf4e85dca66112 (patch)
tree25e53c112303a2aa915d132eb226326f39f9d2b1
downloadaur-76121aec4e8c77f5f79b2b177daf4e85dca66112.tar.gz
Initial commit; version 1.4.0
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD54
-rw-r--r--gegl-0.4.patch80
4 files changed, 168 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..934a10a9ccfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Fri Jan 31 14:47:01 UTC 2020
+pkgbase = lib32-libmypaint
+ pkgdesc = Library for making brushstrokes which is used by MyPaint and other projects (32-bit)
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://mypaint.org/
+ arch = x86_64
+ license = ISC
+ makedepends = intltool
+ makedepends = python
+ makedepends = gobject-introspection
+ makedepends = python
+ depends = libmypaint
+ depends = lib32-glibc
+ depends = lib32-json-c
+ depends = lib32-gegl
+ depends = lib32-glib2
+ depends = lib32-json-glib
+ depends = lib32-babl
+ source = https://github.com/mypaint/libmypaint/archive/v1.4.0/libmypaint-1.4.0.tar.gz
+ source = libmypaint-1.4-gegl-version-revert.patch::https://github.com/anthraxx/libmypaint/commit/5e0290c5fb8a175a9f0dd4c6897ff234361c321f.patch
+ source = gegl-0.4.patch
+ sha512sums = d6c17381dbfc8ee346762f9b4d337ccc691e48b9004f0890c682be0911a2a8c9d35592461d54d55063298c16e81353b1f004f7a0c34bb96d7e511bf9b39cd7a7
+ sha512sums = 313f1d4c20fa8389a184c3a8111d33c8ae99e6c746ee5baf0fe20ba73915296899371eb154ed20fc6b02dccfcd5af53010b9439b70b8d0c4843987c07169b052
+ sha512sums = 0df26f4c8f6f6c31a4d5718d97b3338455fbdb9168167bcae36942f5dc1d5c61db1db2448cfa62cb4551356c7454a7ef91885042cb4529a410d6fc59597fa4b9
+
+pkgname = lib32-libmypaint
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ec2ec9d97a04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+libmypaint-*.tar.gz
+libmypaint-1.4-gegl-version-revert.patch
+lib32-libmypaint-*.pkg.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e01f98fae7dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: twa022 <twa022 at gmail dot com>
+
+pkgname=lib32-libmypaint
+_pkgbase=libmypaint
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Library for making brushstrokes which is used by MyPaint and other projects (32-bit)'
+url='http://mypaint.org/'
+arch=('x86_64')
+license=('ISC')
+depends=('libmypaint' 'lib32-glibc' 'lib32-json-c' 'lib32-gegl'
+ 'lib32-glib2' 'lib32-json-glib' 'lib32-babl')
+makedepends=('intltool' 'python' 'gobject-introspection' 'python')
+source=("https://github.com/mypaint/$_pkgbase/archive/v${pkgver}/${_pkgbase}-${pkgver}.tar.gz"
+ libmypaint-1.4-gegl-version-revert.patch::"https://github.com/anthraxx/$_pkgbase/commit/5e0290c5fb8a175a9f0dd4c6897ff234361c321f.patch"
+ gegl-0.4.patch)
+sha512sums=('d6c17381dbfc8ee346762f9b4d337ccc691e48b9004f0890c682be0911a2a8c9d35592461d54d55063298c16e81353b1f004f7a0c34bb96d7e511bf9b39cd7a7'
+ '313f1d4c20fa8389a184c3a8111d33c8ae99e6c746ee5baf0fe20ba73915296899371eb154ed20fc6b02dccfcd5af53010b9439b70b8d0c4843987c07169b052'
+ '0df26f4c8f6f6c31a4d5718d97b3338455fbdb9168167bcae36942f5dc1d5c61db1db2448cfa62cb4551356c7454a7ef91885042cb4529a410d6fc59597fa4b9')
+
+prepare() {
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ export CFLAGS="-m32"
+ export CXXFLAGS="-m32"
+ cd "${_pkgbase}-${pkgver}"
+ patch -Rp1 < ../libmypaint-1.4-gegl-version-revert.patch
+ patch -Np1 < ../gegl-0.4.patch
+ sed 's|python2|python|' -i autogen.sh
+ ./autogen.sh
+}
+
+build() {
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ export CFLAGS="-m32"
+ export CXXFLAGS="-m32"
+ cd "${_pkgbase}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --enable-gegl
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "${_pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm -r "$pkgdir/usr/"{share,include}
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
diff --git a/gegl-0.4.patch b/gegl-0.4.patch
new file mode 100644
index 000000000000..f5df4e92713d
--- /dev/null
+++ b/gegl-0.4.patch
@@ -0,0 +1,80 @@
+diff -u -r libmypaint-1.3.0/configure.ac libmypaint-1.3.0-gegl/configure.ac
+--- libmypaint-1.3.0/configure.ac 2018-05-13 16:49:44.997077642 +0200
++++ libmypaint-1.3.0-gegl/configure.ac 2018-05-13 16:49:36.223744476 +0200
+@@ -45,7 +45,7 @@
+ [libmypaint_api_major().libmypaint_api_minor().libmypaint_api_micro()m4_bpatsubst(libmypaint_api_prerelease(), [^\(.\)], [-\1])])
+
+ # Dependencies.
+-m4_define([gegl_required_version], [0.3])
++m4_define([gegl_required_version], [0.4])
+ m4_define([introspection_required_version], [1.32.0])
+
+ AC_INIT([libmypaint],
+@@ -336,7 +336,7 @@
+ )
+
+ if eval "test x$enable_gegl = xyes"; then
+- PKG_CHECK_MODULES(GEGL, gegl-0.3 >= gegl_required_version)
++ PKG_CHECK_MODULES(GEGL, gegl-0.4 >= gegl_required_version)
+ fi
+ AM_CONDITIONAL(ENABLE_GEGL, test "x$enable_gegl" = "xyes")
+
+diff -u -r libmypaint-1.3.0/gegl/libmypaint-gegl.pc.in libmypaint-1.3.0-gegl/gegl/libmypaint-gegl.pc.in
+--- libmypaint-1.3.0/gegl/libmypaint-gegl.pc.in 2016-12-01 23:47:14.000000000 +0100
++++ libmypaint-1.3.0-gegl/gegl/libmypaint-gegl.pc.in 2018-05-13 16:50:16.620410376 +0200
+@@ -6,6 +6,6 @@
+ Name: libmypaint
+ Description: MyPaint brush engine library, with GEGL integration.
+ Version: @LIBMYPAINT_VERSION@
+-Requires: gegl-0.3 libmypaint
++Requires: gegl-0.4 libmypaint
+ Cflags: -I${includedir}/libmypaint-gegl
+ Libs: -L${libdir} -lmypaint-gegl
+diff -u -r libmypaint-1.3.0/gegl/Makefile.am libmypaint-1.3.0-gegl/gegl/Makefile.am
+--- libmypaint-1.3.0/gegl/Makefile.am 2018-05-13 16:48:53.437078622 +0200
++++ libmypaint-1.3.0-gegl/gegl/Makefile.am 2018-05-13 16:49:58.523744053 +0200
+@@ -11,7 +11,7 @@
+ INTROSPECTION_GIRS =
+ INTROSPECTION_SCANNER_ARGS = \
+ --warn-all \
+- --pkg="gegl-0.3" \
++ --pkg="gegl-0.4" \
+ --pkg="glib-2.0" \
+ --namespace="MyPaintGegl" \
+ --nsversion="$(LIBMYPAINT_MAJOR_VERSION).$(LIBMYPAINT_MINOR_VERSION)" \
+@@ -38,7 +38,7 @@
+ mypaint-gegl-surface.c
+
+ MyPaintGegl-@LIBMYPAINT_MAJOR_VERSION@.@LIBMYPAINT_MINOR_VERSION@.gir: libmypaint-gegl.la Makefile
+-MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_INCLUDES = GObject-2.0 MyPaint-$(LIBMYPAINT_MAJOR_VERSION).$(LIBMYPAINT_MINOR_VERSION) Gegl-0.3
++MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_INCLUDES = GObject-2.0 MyPaint-$(LIBMYPAINT_MAJOR_VERSION).$(LIBMYPAINT_MINOR_VERSION) Gegl-0.4
+ MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_CFLAGS = $(AM_CFLAGS) $(AM_CPPFLAGS) -I. -I..
+ MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_LIBS = libmypaint-gegl.la ../libmypaint.la
+ MyPaintGegl_@LIBMYPAINT_MAJOR_VERSION@_@LIBMYPAINT_MINOR_VERSION@_gir_FILES = $(introspection_sources)
+
+--- a/gegl/mypaint-gegl-surface.c
++++ b/gegl/mypaint-gegl-surface.c
+@@ -78,7 +78,11 @@ tile_request_start(MyPaintTiledSurface *tiled_surface, MyPaintTileRequest *reque
+
+ if (buffer_is_native(self)) {
+ GeglBufferIterator *iterator = gegl_buffer_iterator_new(self->buffer, &tile_bbox, 0, self->format,
++#if GEGL_MAJOR_VERSION == 0 && GEGL_MINOR_VERSION == 4 && GEGL_MICRO_VERSION >= 14
++ read_write_flags, GEGL_ABYSS_NONE, 8);
++#else
+ read_write_flags, GEGL_ABYSS_NONE);
++#endif
+
+ // Read out
+ gboolean completed = gegl_buffer_iterator_next(iterator);
+@@ -88,7 +92,11 @@ tile_request_start(MyPaintTiledSurface *tiled_surface, MyPaintTileRequest *reque
+ g_critical("Unable to get tile aligned access to GeglBuffer");
+ request->buffer = NULL;
+ } else {
++#if GEGL_MAJOR_VERSION == 0 && GEGL_MINOR_VERSION == 4 && GEGL_MICRO_VERSION >= 14
++ request->buffer = (uint16_t *)(iterator->items[0].data);
++#else
+ request->buffer = (uint16_t *)(iterator->data[0]);
++#endif
+ }
+
+ // So we can finish the iterator in tile_request_end()