summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2020-08-19 22:25:55 -0300
committerRodrigo Bezerra2020-08-19 22:25:55 -0300
commit63433f40f4b3d02adb5aba684904d5bda617d19c (patch)
tree3a12ee3ec946d370a799fe903c2e3f624b1c4bd4
parentb327d813e7d5d7a401b27819cf821dbdf3a93ced (diff)
downloadaur-63433f40f4b3d02adb5aba684904d5bda617d19c.tar.gz
Fix build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4adaeea6142e..4118dcba27ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-libnice
pkgdesc = An implementation of the IETF's draft ICE (for p2p UDP data streams) (32-bit)
pkgver = 0.1.17
- pkgrel = 1
+ pkgrel = 2
url = https://nice.freedesktop.org
arch = x86_64
license = LGPL
diff --git a/PKGBUILD b/PKGBUILD
index 81be6e8aba39..5d507e85d6a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_basename=libnice
pkgname=lib32-libnice
pkgver=0.1.17
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of the IETF's draft ICE (for p2p UDP data streams) (32-bit)"
url="https://nice.freedesktop.org"
arch=(x86_64)
@@ -24,12 +24,14 @@ build() {
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG='/usr/bin/i686-pc-linux-gnu-pkg-config'
- export PKG_CONFIG_PATH='$PKG_CONFIG_PATH:/usr/lib32/pkgconfig/:/usr/lib/pkgconfig'
arch-meson libnice build \
--libdir='/usr/lib32' \
+ -Dexamples=disabled \
+ -Dtests=disabled \
-Dgtk_doc=disabled \
- -Dtests=disabled
+ -Dintrospection=disabled
+
meson compile -C build
}
@@ -41,5 +43,5 @@ check() {
package() {
DESTDIR="${pkgdir}" meson install -C build
- rm -rf "${pkgdir}"/usr/{bin,include,share}
+ rm -rf "${pkgdir}"/usr/{bin,include}
}