summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavorin Učakar2015-06-08 22:53:02 +0200
committerDavorin Učakar2015-06-08 22:53:02 +0200
commit66e0eb3e40ae571e4ccf9460fc68880fbf0323da (patch)
treed04eb39a3a12c83ea66f5c380ec31191b3cbc1b2
downloadaur-66e0eb3e40ae571e4ccf9460fc68880fbf0323da.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--CMakeLists.txt101
-rw-r--r--COPYING18
-rw-r--r--PKGBUILD46
4 files changed, 185 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e849ac886f9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib32-libnoise
+ pkgdesc = A portable, open-source, coherent noise-generating library for C++
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://libnoise.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = unzip
+ depends = lib32-gcc-libs
+ source = http://prdownloads.sourceforge.net/libnoise/libnoisesrc-1.0.0.zip
+ source = CMakeLists.txt
+ source = COPYING
+ md5sums = fc0d9b4f6477397568c3a9d5294b3b8c
+ md5sums = 913a4145cdc7c38d43698386321ea85b
+ md5sums = ff2016bd98a6368367edf64aabab0939
+
+pkgname = lib32-libnoise
+
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000000..a348f2653ffc
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,101 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
+
+PROJECT(libnoise)
+
+SET (LIBNOISE_SRC
+ src/latlon.cpp
+ src/model/cylinder.cpp
+ src/model/line.cpp
+ src/model/plane.cpp
+ src/model/sphere.cpp
+ src/module/abs.cpp
+ src/module/add.cpp
+ src/module/billow.cpp
+ src/module/blend.cpp
+ src/module/cache.cpp
+ src/module/checkerboard.cpp
+ src/module/clamp.cpp
+ src/module/const.cpp
+ src/module/curve.cpp
+ src/module/cylinders.cpp
+ src/module/displace.cpp
+ src/module/exponent.cpp
+ src/module/invert.cpp
+ src/module/max.cpp
+ src/module/min.cpp
+ src/module/modulebase.cpp
+ src/module/multiply.cpp
+ src/module/perlin.cpp
+ src/module/power.cpp
+ src/module/ridgedmulti.cpp
+ src/module/rotatepoint.cpp
+ src/module/scalebias.cpp
+ src/module/scalepoint.cpp
+ src/module/select.cpp
+ src/module/spheres.cpp
+ src/module/terrace.cpp
+ src/module/translatepoint.cpp
+ src/module/turbulence.cpp
+ src/module/voronoi.cpp
+ src/noisegen.cpp
+)
+
+set (BASE_HEADERS
+ src/basictypes.h
+ src/exception.h
+ src/interp.h
+ src/latlon.h
+ src/mathconsts.h
+ src/misc.h
+ src/noise.h
+ src/noisegen.h
+ src/vectortable.h
+)
+
+SET (MODEL_HEADERS
+ src/model/cylinder.h
+ src/model/line.h
+ src/model/model.h
+ src/model/plane.h
+ src/model/sphere.h
+)
+
+SET (MODULE_HEADERS
+ src/module/abs.h
+ src/module/add.h
+ src/module/billow.h
+ src/module/blend.h
+ src/module/cache.h
+ src/module/checkerboard.h
+ src/module/clamp.h
+ src/module/const.h
+ src/module/curve.h
+ src/module/cylinders.h
+ src/module/displace.h
+ src/module/exponent.h
+ src/module/invert.h
+ src/module/max.h
+ src/module/min.h
+ src/module/module.h
+ src/module/modulebase.h
+ src/module/multiply.h
+ src/module/perlin.h
+ src/module/power.h
+ src/module/ridgedmulti.h
+ src/module/rotatepoint.h
+ src/module/scalebias.h
+ src/module/scalepoint.h
+ src/module/select.h
+ src/module/spheres.h
+ src/module/terrace.h
+ src/module/translatepoint.h
+ src/module/turbulence.h
+ src/module/voronoi.h
+)
+
+ADD_LIBRARY (noise SHARED ${LIBNOISE_SRC})
+SET_TARGET_PROPERTIES (noise PROPERTIES VERSION 1.0.0)
+INSTALL(TARGETS noise DESTINATION lib)
+INSTALL(FILES ${BASE_HEADERS} DESTINATION "include/noise")
+INSTALL(FILES ${MODEL_HEADERS} DESTINATION "include/noise/model")
+INSTALL(FILES ${MODULE_HEADERS} DESTINATION "include/noise/module")
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..b73b856e5cc4
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,18 @@
+Copyright (C) 2003, 2004 Jason Bevins
+
+This library is free software; you can redistribute it and/or modify it
+under the terms of the GNU Lesser General Public License as published by
+the Free Software Foundation; either version 2.1 of the License, or (at
+your option) any later version.
+
+This library is distributed in the hope that it will be useful, but WITHOUT
+ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public
+License (COPYING.txt) for more details.
+
+You should have received a copy of the GNU Lesser General Public License
+along with this library; if not, write to the Free Software Foundation,
+Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+The developer's email is jlbezigvins@gmzigail.com (for great email, take
+off every 'zig'.)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30593ed13724
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: jimmy-6
+# Maintainer: Davorin Učakar <davorin.ucakar@gmail.com>
+
+pkgname=lib32-libnoise
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A portable, open-source, coherent noise-generating library for C++"
+arch=('i686' 'x86_64')
+url="http://libnoise.sourceforge.net/"
+license=('LGPL')
+depends=('lib32-gcc-libs')
+makedepends=('cmake' 'unzip')
+source=("http://prdownloads.sourceforge.net/libnoise/libnoisesrc-${pkgver}.zip"
+ 'CMakeLists.txt'
+ 'COPYING')
+md5sums=('fc0d9b4f6477397568c3a9d5294b3b8c'
+ '913a4145cdc7c38d43698386321ea85b'
+ 'ff2016bd98a6368367edf64aabab0939')
+
+prepare() {
+ cp CMakeLists.txt noise
+}
+
+build() {
+ rm -rf build && mkdir build && cd build
+
+ cmake \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_C_FLAGS="-march=i686 -m32 ${CFLAGS/-march=x86_64}" \
+ -D CMAKE_CXX_FLAGS="-march=i686 -m32 ${CXXFLAGS/-march=x86_64}" \
+ ../noise
+ make
+}
+
+package() {
+ cd ${srcdir}/build
+
+ make DESTDIR=${pkgdir} install
+
+ rm -rf ${pkgdir}/usr/include
+ mv ${pkgdir}/usr/lib ${pkgdir}/usr/lib32
+
+ install -Dm 644 ${srcdir}/COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
+}