summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-11-26 13:07:02 -0500
committerVincent Grande2020-11-26 13:07:02 -0500
commitc31a9c4dc411ea4163e09a5883dd5869eb092287 (patch)
tree54934919c489235551ac5244d55ee27d23501e81
downloadaur-c31a9c4dc411ea4163e09a5883dd5869eb092287.tar.gz
fix
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD92
2 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d96aa610da8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = lib32-libpulse-nosystemd-minimal-git
+ pkgdesc = A featureful, general-purpose sound server (32-bit client libraries)
+ pkgver = 13.99.1+98+g460d0c0b7
+ pkgrel = 1
+ url = https://www.freedesktop.org/wiki/Software/PulseAudio/
+ arch = x86_64
+ license = LGPL
+ makedepends = lib32-speexdsp
+ makedepends = lib32-glib2
+ makedepends = git
+ makedepends = meson
+ makedepends = libpulse
+ depends = lib32-dbus
+ depends = lib32-libasyncns
+ depends = lib32-libcap
+ depends = lib32-libxtst
+ depends = lib32-libsm
+ depends = lib32-libsndfile
+ optdepends = lib32-alsa-plugins: ALSA support
+ optdepends = libpulse: 64bit support
+ provides = lib32-pulseaudio
+ provides = lib32-libpulse
+ conflicts = lib32-pulseaudio
+ conflicts = lib32-libpulse
+ replaces = lib32-pulseaudio
+ source = git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git
+ sha256sums = SKIP
+
+pkgname = lib32-libpulse-nosystemd-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6435198decb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,92 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+
+pkgname=lib32-libpulse-nosystemd-minimal-git
+pkgdesc="A featureful, general-purpose sound server (32-bit client libraries)"
+pkgver=13.99.1+98+g460d0c0b7
+pkgrel=1
+arch=(x86_64)
+url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+license=(LGPL)
+depends=(lib32-{dbus,libasyncns,libcap,libxtst,libsm,libsndfile})
+makedepends=(lib32-{speexdsp,glib2} git meson libpulse)
+optdepends=('lib32-alsa-plugins: ALSA support'
+ 'libpulse: 64bit support')
+provides=(lib32-pulseaudio lib32-libpulse)
+conflicts=(lib32-pulseaudio lib32-libpulse)
+replaces=(lib32-pulseaudio)
+source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pulseaudio
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd pulseaudio
+
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG="i686-pc-linux-gnu-pkg-config"
+
+ arch-meson pulseaudio build \
+ --libdir /usr/lib32 \
+ --auto-features auto \
+ -D man=false \
+ -D tests=false \
+ -D avahi=disabled \
+ -D bluez5=false \
+ -D gcov=false \
+ -D systemd=disabled \
+ -D legacy-database-entry-format=false \
+ -D asyncns=disabled \
+ -D bluez5-native-headset=false \
+ -D bluez5-ofono-headset=false \
+ -D dbus=disabled \
+ -D fftw=disabled \
+ -D glib=disabled \
+ -D gsettings=disabled \
+ -D gstreamer=disabled \
+ -D gtk=disabled \
+ -D ipv6=false \
+ -D jack=disabled \
+ -D lirc=disabled \
+ -D openssl=disabled \
+ -D soxr=disabled \
+ -D speex=disabled \
+ -D adrian-aec=true \
+ -D webrtc-aec=disabled
+ -D pulsedsp-location='/usr/\$LIB/pulseaudio' \
+ -D stream-restore-clear-old-devices=true \
+ -D udevrulesdir=/usr/lib/udev/rules.d
+ meson compile -C build
+}
+
+#check() {
+# meson test -C build --print-errorlogs
+#}
+
+_pick() {
+ local f d
+ for f; do
+ d="$pkgdir/${f#$srcdir/install/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
+}
+
+package() {
+ DESTDIR="$srcdir/install" meson install -C build
+
+ cd install
+ _pick usr/lib32/libpulse{,-simple,}.so*
+ _pick usr/lib32/{cmake,pkgconfig}
+ _pick usr/lib32/pulseaudio/libpulse{dsp,common-*}.so
+}
+# vim:set sw=2 et:
+