summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2016-06-06 16:43:20 +0900
committerorumin2016-06-06 16:43:20 +0900
commit82c01786362fce85887b835a8ad551ae462472bd (patch)
treef7ccff1598f56999dd5087516f3b590a8b542be6
downloadaur-82c01786362fce85887b835a8ad551ae462472bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75e426983a0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jun 6 07:43:15 UTC 2016
+pkgbase = lib32-libsrtp
+ pkgdesc = Library for SRTP (Secure Realtime Transport Protocol) (32-bit)
+ pkgver = 1.5.4
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/cisco/libsrtp
+ arch = x86_64
+ license = BSD
+ depends = lib32-glibc
+ depends = libsrtp
+ options = staticlibs
+ source = libsrtp-1.5.4.tar.gz::https://github.com/cisco/libsrtp/archive/v1.5.4.tar.gz
+ sha256sums = 56a7b521c25134f48faff26b0b1e3d4378a14986a2d3d7bc6fefb48987304ff0
+
+pkgname = lib32-libsrtp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..406a3bfc0903
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: orumin <dev@orum.in>
+
+_basename=libsrtp
+pkgname="lib32-$_basename"
+pkgver=1.5.4
+pkgrel=1
+epoch=1
+pkgdesc="Library for SRTP (Secure Realtime Transport Protocol) (32-bit)"
+url="https://github.com/cisco/libsrtp"
+arch=('x86_64')
+license=(BSD)
+depends=('lib32-glibc' 'libsrtp')
+options=('staticlibs')
+source=("$_basename-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('56a7b521c25134f48faff26b0b1e3d4378a14986a2d3d7bc6fefb48987304ff0')
+
+prepare() {
+ cd $_basename-$pkgver
+ autoreconf -fvi
+}
+
+build() {
+ cd $_basename-$pkgver
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr \
+ --build=i686-pc-linux-gnu --libdir=/usr/lib32
+ make libsrtp.a shared_library
+}
+
+package() {
+ cd $_basename-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ cd "$pkgdir"/usr
+ rm -r include
+}