summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-09 21:48:18 -0500
committerVincent Grande2021-01-09 21:48:18 -0500
commita419d41be2aea359340d11a2de461e2eac9f1fc3 (patch)
treee0a49d47ae1760fe811fe17b9b13b9eefd5b48d1
downloadaur-a419d41be2aea359340d11a2de461e2eac9f1fc3.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26c9f882c69e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lib32-libtasn1-git
+ pkgdesc = The ASN.1 library used in GNUTLS (32 bit)
+ pkgver = 4.16.0
+ pkgrel = 1
+ url = https://www.gnu.org/software/libtasn1/
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = gcc-multilib
+ depends = lib32-glibc
+ depends = libtasn1
+ provides = lib32-libtasn1
+ conflicts = lib32-libtasn1
+ source = git+https://gitlab.com/gnutls/libtasn1.git
+ sha256sums = SKIP
+
+pkgname = lib32-libtasn1-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ad566ecf2ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Florian Pritz <bluewind@xinu.at>
+# Contributor: josephgbr <rafael.f.f1 at gmail.com>
+
+_pkgbase=libtasn1
+pkgname=lib32-${_pkgbase}-git
+pkgver=4.16.0
+pkgrel=1
+pkgdesc="The ASN.1 library used in GNUTLS (32 bit)"
+arch=('x86_64')
+license=('GPL3' 'LGPL')
+url="https://www.gnu.org/software/libtasn1/"
+depends=('lib32-glibc' ${_pkgbase})
+makedepends=('gcc-multilib')
+provides=(lib32-libtasn1)
+conflicts=(lib32-libtasn1)
+source=("git+https://gitlab.com/gnutls/libtasn1.git")
+sha256sums=('SKIP')
+#validpgpkeys=('1F42418905D8206AA754CCDC29EE58B996865171') #Nikos Mavrogiannopoulos <nmav@gnutls.org>
+
+pkgver() {
+ cd libtasn1
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ cd ${_pkgbase}
+
+ ./bootstrap
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --with-packager=Archlinux \
+ --with-packager-bug-reports="http://bugs.archlinux.org/" \
+ --with-packager-version=${pkgver}-${pkgrel}
+ make
+}
+
+package() {
+ cd ${_pkgbase}
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}/usr/"{bin,include,share}
+}