summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2020-05-26 19:55:55 -0300
committerRodrigo Bezerra2020-05-26 19:55:55 -0300
commitedf73e78109c5354add9e4b6e124bb9d229fd1ab (patch)
tree41eda333895829df73062ee1d5b37546a5177e84
parent90bc168ac03a2a92845c6e5cb59ed936aade0e04 (diff)
downloadaur-edf73e78109c5354add9e4b6e124bb9d229fd1ab.tar.gz
Use tarball from videolan.org
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Fix-automake.patch49
-rw-r--r--PKGBUILD24
3 files changed, 11 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06c81249a6cf..3311f6a2158d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = lib32-libtiger
pkgdesc = A rendering library for Kate streams using Pango and Cairo (32-bit)
pkgver = 0.3.4
- pkgrel = 3
- url = http://git.xiph.org/?p=users/oggk/tiger.git;a=summary
+ pkgrel = 4
+ url = https://code.google.com/archive/p/libtiger/
arch = x86_64
license = LGPL
makedepends = pkg-config
- makedepends = git
depends = lib32-pango
depends = lib32-libkate
depends = libtiger
- source = libtiger::git+git://git.xiph.org/users/oggk/tiger.git#tag=tiger-0.3.4
- source = 0001-Fix-automake.patch
- sha256sums = SKIP
- sha256sums = fa257ad2dfceb6709633e6515bbbe04b8dad5bcb3c9226c7b5d2b3871336b6f4
+ source = https://download.videolan.org/contrib/tiger/libtiger-0.3.4.tar.gz
+ md5sums = dc1dbeb658c95485ba10b9b2897b4ae2
pkgname = lib32-libtiger
diff --git a/0001-Fix-automake.patch b/0001-Fix-automake.patch
deleted file mode 100644
index 1eecd9826d6d..000000000000
--- a/0001-Fix-automake.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From b1f7c2dafaab5ed57d28ad241ffc93d55043e849 Mon Sep 17 00:00:00 2001
-From: Jelle van der Waa <j.vanderwaa@kopano.com>
-Date: Wed, 21 Jun 2017 13:57:18 +0200
-Subject: [PATCH] Fix automake
-
----
- Makefile.am | 2 --
- configure.ac | 1 +
- doc/Makefile.am | 2 --
- 3 files changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index c5d6b6e..644a1a9 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -11,8 +11,6 @@ tigerinc_HEADERS=include/tiger/tiger.h include/tiger/tiger_config.h
- tigerpc_DATA=misc/pkgconfig/tiger.pc
- noinst_DATA=misc/pkgconfig/tiger-uninstalled.pc
-
--LIBTOOLFLAGS=--silent
--
- AM_CPPFLAGS=-I $(top_srcdir)/src -I $(top_srcdir)/include
-
- lib_libtiger_la_SOURCES=\
-diff --git a/configure.ac b/configure.ac
-index 2f63684..ae5f971 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -26,6 +26,7 @@ dnl then set AGE to 0.
-
- LIBTIGER_SHARED_VERSION="5:2:0"
-
-+AM_PROG_AR
- AC_PROG_CC_C_O
- AC_PROG_LIBTOOL
- AC_PROG_GREP
-diff --git a/doc/Makefile.am b/doc/Makefile.am
-index 70d48c5..d5aff38 100644
---- a/doc/Makefile.am
-+++ b/doc/Makefile.am
-@@ -1,5 +1,3 @@
--LIBTOOLFLAGS=--silent
--
- # dependency to get doc to be built
- noinst_DATA = .doc-dummy-target
-
---
-2.13.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 5f0f44f6b1b4..9f913ceb3d49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,18 @@
_basename=libtiger
pkgname=lib32-libtiger
pkgver=0.3.4
-pkgrel=3
+pkgrel=4
pkgdesc="A rendering library for Kate streams using Pango and Cairo (32-bit)"
-url="http://git.xiph.org/?p=users/oggk/tiger.git;a=summary"
+url="https://code.google.com/archive/p/libtiger/"
license=('LGPL')
arch=('x86_64')
depends=('lib32-pango' 'lib32-libkate' 'libtiger')
-makedepends=('pkg-config' 'git')
-source=("$_basename::git+git://git.xiph.org/users/oggk/tiger.git#tag=tiger-$pkgver"
- "0001-Fix-automake.patch")
-sha256sums=('SKIP'
- 'fa257ad2dfceb6709633e6515bbbe04b8dad5bcb3c9226c7b5d2b3871336b6f4')
-
-prepare() {
- cd $_basename
-
- patch -Np1 -i "${srcdir}/0001-Fix-automake.patch"
-
- ./autogen.sh
-}
+makedepends=('pkg-config')
+source=(https://download.videolan.org/contrib/tiger/$_basename-$pkgver.tar.gz)
+md5sums=('dc1dbeb658c95485ba10b9b2897b4ae2')
build() {
- cd $_basename
+ cd $_basename-$pkgver
export CC='gcc -m32'
export CXX='g++ -m32'
@@ -42,7 +32,7 @@ build() {
}
package() {
- cd $_basename
+ cd $_basename-$pkgver
make DESTDIR="${pkgdir}" install