summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tia2015-06-12 19:38:29 -0600
committerJavier Tia2015-06-12 19:38:29 -0600
commitfe2d9680ac69eee04e8c9535c414376c01945a01 (patch)
tree10aa851be2ad1991fc201f677a9d47da964e063b
downloadaur-fe2d9680ac69eee04e8c9535c414376c01945a01.tar.gz
New package lib32-libtins v3.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
-rw-r--r--Set-where-find-and-install-32-bits-libraries.patch54
3 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4aaafa95c5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lib32-libtins
+ pkgdesc = 32-bit A high-level, multiplatform C++ network packet sniffing and crafting library
+ pkgver = 3.2
+ pkgrel = 1
+ url = http://libtins.github.io/
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = lib32-libpcap
+ depends = lib32-openssl
+ depends = libtins
+ options = !libtool
+ source = https://github.com/mfontanini/libtins/archive/v3.2.tar.gz
+ source = Set-where-find-and-install-32-bits-libraries.patch
+ sha256sums = 7f11c8b6c33574fcc48a5310557320d7eff7216d28e6f7062ea3e4745f2ce4fc
+ sha256sums = 97d41800372ebf25dff241fb84c58e1d798cc9fc16c17b0e528a5f28efcfd99d
+
+pkgname = lib32-libtins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b967c700f073
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Javier Tia <javier.tia at gmail dot com>
+
+pkgname=lib32-libtins
+pkgver=3.2
+pkgrel=1
+pkgdesc="32-bit A high-level, multiplatform C++ network packet sniffing and crafting library"
+arch=('x86_64')
+url="http://libtins.github.io/"
+license=('BSD')
+depends=('lib32-libpcap' 'lib32-openssl' 'libtins')
+makedepends=('cmake')
+options=('!libtool')
+source=(
+ "https://github.com/mfontanini/libtins/archive/v${pkgver}.tar.gz"
+ "Set-where-find-and-install-32-bits-libraries.patch"
+)
+
+sha256sums=(
+ '7f11c8b6c33574fcc48a5310557320d7eff7216d28e6f7062ea3e4745f2ce4fc'
+ '97d41800372ebf25dff241fb84c58e1d798cc9fc16c17b0e528a5f28efcfd99d'
+)
+
+prepare() {
+ cd "${srcdir}"/libtins-${pkgver}
+ mkdir build
+ patch -Np1 -i ${srcdir}/Set-where-find-and-install-32-bits-libraries.patch
+}
+
+build() {
+ cd "${srcdir}"/libtins-${pkgver}/build
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ cmake -D CMAKE_BUILD_TYPE=Release -D LIBTINS_ENABLE_CXX11=yes \
+ -D CMAKE_INSTALL_PREFIX=/usr ../
+ make -j8
+}
+
+package() {
+ cd "${srcdir}"/libtins-${pkgver}/build
+ make DESTDIR="${pkgdir}" install
+ rm -R "${pkgdir}"/usr/{CMake,include}/
+}
+
diff --git a/Set-where-find-and-install-32-bits-libraries.patch b/Set-where-find-and-install-32-bits-libraries.patch
new file mode 100644
index 000000000000..db3b77039c2e
--- /dev/null
+++ b/Set-where-find-and-install-32-bits-libraries.patch
@@ -0,0 +1,54 @@
+From 1d01cfbe5efc8f7e594a38fe7ef37aa552059c7b Mon Sep 17 00:00:00 2001
+From: Javier Tia <javier.tia@hp.com>
+Date: Wed, 25 Mar 2015 09:33:09 -0600
+Subject: [PATCH] Set where find and install 32-bits libraries
+
+---
+ CMakeLists.txt | 2 +-
+ cmake/Modules/FindPCAP.cmake | 2 +-
+ src/CMakeLists.txt | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 726d6ce..16643db 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -107,7 +107,7 @@ CONFIGURE_FILE(
+ )
+
+ # Support for pkg-config
+-set(CMAKE_INSTALL_LIBDIR lib)
++set(CMAKE_INSTALL_LIBDIR lib32)
+ set(pkgconfig_prefix ${CMAKE_INSTALL_PREFIX})
+ set(pkgconfig_exec_prefix ${CMAKE_INSTALL_PREFIX})
+ set(pkgconfig_libdir ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+diff --git a/cmake/Modules/FindPCAP.cmake b/cmake/Modules/FindPCAP.cmake
+index b3a3075..651f638 100644
+--- a/cmake/Modules/FindPCAP.cmake
++++ b/cmake/Modules/FindPCAP.cmake
+@@ -30,7 +30,7 @@ find_path(PCAP_INCLUDE_DIR
+
+ find_library(PCAP_LIBRARY
+ NAMES pcap wpcap
+- HINTS ${PCAP_ROOT_DIR}/lib
++ HINTS ${PCAP_ROOT_DIR}/lib32
+ )
+
+ include(FindPackageHandleStandardArgs)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 25a93ce..73605c6 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -69,7 +69,7 @@ SET_TARGET_PROPERTIES(tins PROPERTIES VERSION ${LIBTINS_VERSION} SOVERSION ${LIB
+ INSTALL(
+ TARGETS tins
+ EXPORT libtinsTargets
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ LIBRARY DESTINATION lib32
++ ARCHIVE DESTINATION lib32
+ COMPONENT dev
+ )
+--
+2.3.3
+