summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorllde2018-12-29 01:37:52 +0100
committerllde2018-12-29 01:37:52 +0100
commitb94fbf4f371e3de9fee042e2d3eb0f1b1c04dd7a (patch)
treefbaebdfc03633ce66fba8ad974986e5eafa57cfe
downloadaur-b94fbf4f371e3de9fee042e2d3eb0f1b1c04dd7a.tar.gz
Restored a lost lib needed for a wine-staging patch
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a9e52207f16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lib32-libtxc_dxtn
+ pkgdesc = the S3TC algorithm, needed by wine-staging DXTn patches
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://dri.freedesktop.org/wiki/S3TC
+ arch = x86_64
+ license = BSD
+ depends = lib32-mesa
+ provides = lib32-libtxc_dxtn
+ source = http://people.freedesktop.org/~cbrill/libtxc_dxtn/libtxc_dxtn-1.0.1.tar.bz2
+ md5sums = 7105107f07ac49753f4b61ba9d0c79c5
+
+pkgname = lib32-libtxc_dxtn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d57f168ccb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Your Name <youremail@domain.com>
+_pkgname=libtxc_dxtn
+pkgname=lib32-$_pkgname
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="the S3TC algorithm, needed by wine-staging DXTn patches"
+arch=('x86_64')
+url="http://dri.freedesktop.org/wiki/S3TC"
+license=('BSD')
+depends=('lib32-mesa')
+provides=('lib32-libtxc_dxtn')
+source=("http://people.freedesktop.org/~cbrill/$_pkgname/$_pkgname-$pkgver.tar.bz2")
+md5sums=('7105107f07ac49753f4b61ba9d0c79c5')
+
+build() {
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ cd "$_pkgname-$pkgver"
+ ./configure --prefix=/usr --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ rm "$pkgdir/usr/include" -Rf
+}
+