summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-09-20 14:06:29 -0400
committerVincent Grande2020-09-20 14:06:29 -0400
commit2f30c49a3f6b8a483bceedae21a402fc662d2527 (patch)
treed1cb80b66dc9895c2835c3cc8c0518b24bf878f0
downloadaur-2f30c49a3f6b8a483bceedae21a402fc662d2527.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e15c238b197
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lib32-libxcursor-git
+ pkgdesc = X cursor management library (32-bit)
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = x86_64
+ license = custom
+ makedepends = xorg-util-macros
+ depends = lib32-libxfixes
+ depends = lib32-libxrender
+ depends = libxcursor
+ provides = lib32-libxcursor
+ conflicts = lib32-libxcursor
+ source = git+https://gitlab.freedesktop.org/xorg/lib/libxcursor
+ sha256sums = SKIP
+
+pkgname = lib32-libxcursor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ddf494bf31b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
+
+pkgname=lib32-libxcursor-git
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="X cursor management library (32-bit)"
+arch=(x86_64)
+url="https://xorg.freedesktop.org/"
+license=('custom')
+provides=(lib32-libxcursor)
+conflicts=(lib32-libxcursor)
+depends=('lib32-libxfixes' 'lib32-libxrender' libxcursor)
+makedepends=('xorg-util-macros')
+source=(git+https://gitlab.freedesktop.org/xorg/lib/libxcursor)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd libxcursor
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd libxcursor
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-static --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd libxcursor
+
+ make DESTDIR=${pkgdir} install
+
+ rm -rf "${pkgdir}"/usr/{include,share,bin}
+ mkdir -p "$pkgdir/usr/share/licenses"
+ ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
+}