summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-08-11 12:39:44 -0400
committerAndrew Sun2018-08-11 12:39:44 -0400
commit5f5d2242288c264d75737f8ae5957015d546251c (patch)
treeb6884a5fed17965cba1db730d8e87f718bf9fb7d
downloadaur-5f5d2242288c264d75737f8ae5957015d546251c.tar.gz
add lib32-libyaml (version 0.2.1)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e6db6878537
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lib32-libyaml
+ pkgdesc = YAML 1.1 library (32-bit)
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = http://pyyaml.org/wiki/LibYAML
+ arch = x86_64
+ license = MIT
+ makedepends = lib32-gcc-libs
+ depends = lib32-glibc
+ depends = libyaml
+ source = http://pyyaml.org/download/libyaml/yaml-0.2.1.tar.gz
+ md5sums = 72724b9736923c517e5a8fc6757ef03d
+
+pkgname = lib32-libyaml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4a15c64829e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+pkgname=lib32-libyaml
+_pkgname=libyaml
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="YAML 1.1 library (32-bit)"
+arch=('x86_64')
+url="http://pyyaml.org/wiki/LibYAML"
+license=('MIT')
+depends=('lib32-glibc' "${_pkgname}")
+makedepends=('lib32-gcc-libs')
+source=("http://pyyaml.org/download/libyaml/yaml-${pkgver}.tar.gz")
+md5sums=('72724b9736923c517e5a8fc6757ef03d')
+
+build() {
+ cd "${srcdir}/yaml-${pkgver}"
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "${srcdir}/yaml-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ rm -rf ${pkgdir}/usr/{include,share}
+}