summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2015-07-28 19:45:57 -0400
committerTed Alff2015-07-28 19:45:57 -0400
commit673b834639b02cee53479e37dd533732fff4e650 (patch)
tree92f0a549b230c0a51cd539d8710ca78c4e7c82c2
downloadaur-673b834639b02cee53479e37dd533732fff4e650.tar.gz
Initial AUR4 import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4cf5cd47e8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-libzip1
+ pkgdesc = A C library for reading, creating, and modifying zip archives
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = http://www.nih.at/libzip/index.html
+ arch = x86_64
+ license = BSD
+ makedepends = gcc-multilib
+ depends = libzip1
+ depends = lib32-zlib
+ depends = lib32-glibc
+ options = !libtool
+ source = http://www.nih.at/libzip/libzip-0.9.3.tar.gz
+ sha256sums = 0e282dfed9e3da7d52223a0ccaee7c950782f10ed73f9b778243128a03c8cb1c
+
+pkgname = lib32-libzip1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb790e32a734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=libzip
+pkgname=lib32-${_pkgname}1
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="A C library for reading, creating, and modifying zip archives"
+url="http://www.nih.at/libzip/index.html"
+license=('BSD')
+arch=('x86_64')
+depends=('libzip1' 'lib32-zlib' 'lib32-glibc')
+makedepends=('gcc-multilib')
+options=('!libtool')
+source=("http://www.nih.at/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ #autoreconf -i
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ ./configure --prefix=/usr --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ rm -r "${pkgdir}"/usr/{bin,include,share}
+ rm -r "${pkgdir}"/usr/lib32/{libzip.a,libzip.so,pkgconfig}
+}
+
+sha256sums=('0e282dfed9e3da7d52223a0ccaee7c950782f10ed73f9b778243128a03c8cb1c')