summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-11-05 22:08:53 +0100
committerLW-archlinux2019-11-05 22:08:53 +0100
commita36f0408d601e9e4d3ce3249d015e7834484d7eb (patch)
tree98a1eb29888369a56dc91a49f1bf0e1daa47546f
parent9da2277a209cccb27ab5e814a7dc95a378d07964 (diff)
downloadaur-a36f0408d601e9e4d3ce3249d015e7834484d7eb.tar.gz
reverted clang support as it gave problems
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 005323d84846..5f7f74fc4001 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = lib32-llvm-minimal-git
- pkgver = 10.0.0_r330756.8d7bd575264
+ pkgver = 10.0.0_r331158.a078c77d720
pkgrel = 1
url = http://llvm.org/
arch = x86_64
@@ -19,7 +19,7 @@ pkgbase = lib32-llvm-minimal-git
pkgname = lib32-llvm-minimal-git
pkgdesc = Collection of modular and reusable compiler and toolchain technologies (32-bit)
- depends = lib32-llvm-libs-minimal-git=10.0.0_r330756.8d7bd575264-1
+ depends = lib32-llvm-libs-minimal-git=10.0.0_r331158.a078c77d720-1
depends = llvm-minimal-git
conflicts = lib32-llvm
diff --git a/PKGBUILD b/PKGBUILD
index 56702c55353d..aaa542d895f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@
pkgbase=lib32-llvm-minimal-git
pkgname=('lib32-llvm-minimal-git' 'lib32-llvm-libs-minimal-git')
-pkgver=10.0.0_r330756.8d7bd575264
+pkgver=10.0.0_r331158.a078c77d720
pkgrel=1
arch=('x86_64')
url="http://llvm.org/"
@@ -56,7 +56,7 @@ prepare() {
cd llvm-project
# remove code parts not needed to build this package
- rm -rf debuginfo-tests libclc libcxx libcxxabi libunwind lld lldb llgo openmp parallel-libs polly pstl
+ rm -rf debuginfo-tests libclc libcxx libcxxabi libunwind lld lldb llgo openmp parallel-libs polly pstl clang clang-tools-extra compiler-rt
}
build() {
@@ -88,7 +88,6 @@ build() {
-D LLVM_BINUTILS_INCDIR=/usr/include \
-D LLVM_VERSION_SUFFIX="" \
-D LLVM_ENABLE_BINDINGS=OFF \
- -D LLVM_ENABLE_PROJECTS="compiler-rt;clang-tools-extra;clang"
ninja $NINJAFLAGS
}