summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-04-07 19:12:05 +0200
committerLone_Wolf2021-04-07 19:12:05 +0200
commitf24354b355cdabe7cba860fe4947df68be21df6a (patch)
treead18a67482adf37c8c784ae1b0ae8674c5a66850
parent49d3555ac3b875511668627af2a13babf2942e7f (diff)
downloadaur-f24354b355cdabe7cba860fe4947df68be21df6a.tar.gz
upstream reverted llvm-shlib: Create object libraries for each component, patch removed
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch54
3 files changed, 6 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4f1b025dcf8..89600401ae79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = lib32-llvm-minimal-git
- pkgver = 13.0.0_r384581.98d5db3e3a3f
+ pkgver = 13.0.0_r384835.672f67300466
pkgrel = 1
url = http://llvm.org/
arch = x86_64
@@ -15,15 +15,12 @@ pkgbase = lib32-llvm-minimal-git
makedepends = llvm-minimal-git
options = staticlibs
source = llvm-project::git+https://github.com/llvm/llvm-project.git
- source = local://llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch
md5sums = SKIP
- md5sums = 5c9db72a8239005aaae0b2790c1df84f
sha512sums = SKIP
- sha512sums = ffc3d1bc65c3b28ecf2b593ffbdb1bc426dd8291219b2d2e219ab458d704687293246f4a31459b1ddb50e18482884a36815a47234bb02f59fb4280cf2223d8b1
pkgname = lib32-llvm-minimal-git
pkgdesc = Collection of modular and reusable compiler and toolchain technologies (32-bit)
- depends = lib32-llvm-libs-minimal-git=13.0.0_r384581.98d5db3e3a3f-1
+ depends = lib32-llvm-libs-minimal-git=13.0.0_r384835.672f67300466-1
depends = llvm-minimal-git
provides = lib32-llvm
conflicts = lib32-llvm
diff --git a/PKGBUILD b/PKGBUILD
index dfc71cabf34b..9b9274c15caf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,19 +19,16 @@
pkgbase=lib32-llvm-minimal-git
pkgname=('lib32-llvm-minimal-git' 'lib32-llvm-libs-minimal-git')
-pkgver=13.0.0_r384581.98d5db3e3a3f
+pkgver=13.0.0_r384835.672f67300466
pkgrel=1
arch=('x86_64')
url="http://llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
makedepends=('git' 'cmake' 'ninja' 'lib32-libffi' 'lib32-zlib' 'python' 'lib32-gcc-libs'
'lib32-libxml2' 'llvm-minimal-git')
-source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
- 'local://llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch')
-md5sums=('SKIP'
- '5c9db72a8239005aaae0b2790c1df84f')
-sha512sums=('SKIP'
- 'ffc3d1bc65c3b28ecf2b593ffbdb1bc426dd8291219b2d2e219ab458d704687293246f4a31459b1ddb50e18482884a36815a47234bb02f59fb4280cf2223d8b1')
+source=("llvm-project::git+https://github.com/llvm/llvm-project.git")
+md5sums=('SKIP')
+sha512sums=('SKIP')
options=('staticlibs')
# NINJAFLAGS is an env var used to pass commandline options to ninja
@@ -51,11 +48,6 @@ pkgver() {
echo "${_pkgver}"
}
-prepare() {
- cd llvm-project
- patch --reverse --strip=1 --input="${srcdir}/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch"
-}
-
build() {
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
diff --git a/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch b/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch
deleted file mode 100644
index 6e6797276359..000000000000
--- a/llvm-shlib_Create_object_libraries_for_each_component_and_link_against_them.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 43ceb74eb1a5801662419fb66a6bf0d5414f1ec5 Mon Sep 17 00:00:00 2001
-From: Tom Stellard <tstellar@redhat.com>
-Date: Wed, 31 Mar 2021 21:35:04 -0700
-Subject: [PATCH] llvm-shlib: Create object libraries for each component and
- link against them
-
-This makes it possible to build libLLVM.so without first creating a
-static library for each component. In the case where only libLLVM.so is
-built (i.e. ninja LLVM) this eliminates 150 linker jobs.
-
-Reviewed By: stellaraccident
-
-Differential Revision: https://reviews.llvm.org/D95727
----
- llvm/cmake/modules/AddLLVM.cmake | 3 ++-
- llvm/tools/llvm-shlib/CMakeLists.txt | 4 ++++
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/llvm/cmake/modules/AddLLVM.cmake b/llvm/cmake/modules/AddLLVM.cmake
-index 2f055c7799624..c7a50b7a393ef 100644
---- a/llvm/cmake/modules/AddLLVM.cmake
-+++ b/llvm/cmake/modules/AddLLVM.cmake
-@@ -488,6 +488,7 @@ function(llvm_add_library name)
- add_dependencies(${obj_name} ${link_lib})
- endif()
- endforeach()
-+ target_link_libraries(${obj_name} ${ARG_LINK_LIBS})
- endif()
- endif()
-
-@@ -746,7 +747,7 @@ function(add_llvm_component_library name)
- "COMPONENT_NAME;ADD_TO_COMPONENT"
- ""
- ${ARGN})
-- add_llvm_library(${name} COMPONENT_LIB ${ARG_UNPARSED_ARGUMENTS})
-+ add_llvm_library(${name} COMPONENT_LIB OBJECT ${ARG_UNPARSED_ARGUMENTS})
- string(REGEX REPLACE "^LLVM" "" component_name ${name})
- set_property(TARGET ${name} PROPERTY LLVM_COMPONENT_NAME ${component_name})
-
-diff --git a/llvm/tools/llvm-shlib/CMakeLists.txt b/llvm/tools/llvm-shlib/CMakeLists.txt
-index b0ee19049e6fa..728995ad8b299 100644
---- a/llvm/tools/llvm-shlib/CMakeLists.txt
-+++ b/llvm/tools/llvm-shlib/CMakeLists.txt
-@@ -33,6 +33,10 @@ if(LLVM_BUILD_LLVM_DYLIB)
- add_llvm_library(LLVM SHARED DISABLE_LLVM_LINK_LLVM_DYLIB SONAME ${INSTALL_WITH_TOOLCHAIN} ${SOURCES})
-
- list(REMOVE_DUPLICATES LIB_NAMES)
-+
-+ # Link against the object libraries instead of static libraries.
-+ list(TRANSFORM LIB_NAMES PREPEND "obj.")
-+
- if(("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux") OR (MINGW) OR (HAIKU)
- OR ("${CMAKE_SYSTEM_NAME}" STREQUAL "FreeBSD")
- OR ("${CMAKE_SYSTEM_NAME}" STREQUAL "GNU")