summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuchesar V. ILIEV2015-11-05 17:31:58 +0200
committerLuchesar V. ILIEV2015-11-05 17:44:18 +0200
commitc0e51e9169e44d770183fcc46611f3434f1f2482 (patch)
tree25f83108ed42323c5057f1b0cfd95f084c065a97
parentb9c21b1441e8c9540406891fa0a40659792ea7ef (diff)
downloadaur-c0e51e9169e44d770183fcc46611f3434f1f2482.tar.gz
Update for r251411 and r252093 from upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ba27f57a2ef..10fcfa5076c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = lib32-llvm-svn
- pkgver = 3.8.0svn_r249946
+ pkgver = 3.8.0svn_r252170
pkgrel = 1
url = http://llvm.org/
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = lib32-llvm-svn
pkgname = lib32-llvm-svn
pkgdesc = The LLVM Compiler Infrastructure (32-bit)
- depends = lib32-llvm-libs-svn=3.8.0svn_r249946-1
+ depends = lib32-llvm-libs-svn=3.8.0svn_r252170-1
depends = llvm-svn
provides = lib32-llvm
conflicts = lib32-llvm
@@ -41,7 +41,7 @@ pkgname = lib32-clang-svn
pkgdesc = C language family frontend for LLVM (32-bit)
url = http://clang.llvm.org/
depends = clang
- depends = lib32-llvm-svn=3.8.0svn_r249946-1
+ depends = lib32-llvm-svn=3.8.0svn_r252170-1
provides = lib32-clang
conflicts = lib32-clang
replaces = lib32-clang
diff --git a/PKGBUILD b/PKGBUILD
index 7b0db1f83f28..639b72a66a6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgname=(
)
_pkgname='llvm'
-pkgver=3.8.0svn_r249946
+pkgver=3.8.0svn_r252170
pkgrel=1
arch=('x86_64')
@@ -87,7 +87,6 @@ build() {
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
# LLVM_BUILD_LLVM_DYLIB: Build the dynamic runtime libraries (e.g. libLLVM.so).
- # LLVM_DYLIB_EXPORT_ALL: Export all symbols in the dynamic libs, not just the C API.
# LLVM_LINK_LLVM_DYLIB: Link our own tools against the libLLVM dynamic library, too.
# LLVM_BINUTILS_INCDIR: Set to binutils' plugin-api.h location in order to build LLVMgold.
# LLVM_TARGET_ARCH: Theoretically, LLVM_BUILD_32_BITS should be used instead, which
@@ -106,7 +105,6 @@ build() {
-DFFI_INCLUDE_DIR:PATH="$(pkg-config --variable=includedir libffi)" \
-DFFI_LIBRARY_DIR:PATH="$(pkg-config --variable=libdir libffi)" \
-DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
- -DLLVM_DYLIB_EXPORT_ALL:BOOL=ON \
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
-DLLVM_BINUTILS_INCDIR:PATH=/usr/include \
"../${_pkgname}"
@@ -142,7 +140,7 @@ package_lib32-llvm-svn() {
make DESTDIR="${pkgdir}" install
# The runtime libraries get installed in llvm-libs-svn
- rm -f "${pkgdir}"/usr/lib32/lib{LLVM,LTO}.so{,.*}
+ rm -f "${pkgdir}"/usr/lib32/lib{LLVM,LTO}{,-*}.so
mv -f "${pkgdir}"/usr/lib32/{BugpointPasses,LLVMgold}.so "${srcdir}/"
# Clang libraries go to a separate package
@@ -194,14 +192,11 @@ package_lib32-llvm-libs-svn() {
# Must have a symlink that corresponds to the output of `llvm-config --version`.
# Without it, some builds, e.g. Mesa, might fail for "lack of shared libraries".
- for _shlib in lib{LLVM,LTO} ; do
- # libLLVM.so.3.8.0svn-r123456
- ln -s "${_shlib}.so.$(echo ${pkgver} | cut -d _ -f 1)" \
- "${pkgdir}/usr/lib32/${_shlib}.so.$(echo ${pkgver} | tr _ -)"
- # libLLVM-3.8.0svn-r123456.so
- ln -s "${_shlib}.so.$(echo ${pkgver} | cut -d _ -f 1)" \
- "${pkgdir}/usr/lib32/${_shlib}-$(echo ${pkgver} | tr _ -).so"
- done
+ _sover="$(echo ${pkgver} | cut -d . -f -2)svn"
+ # libLLVM.so.3.8.0svn-r123456
+ ln -s "libLLVM-${_sover}.so" "${pkgdir}/usr/lib32/libLLVM.so.$(echo ${pkgver} | tr _ -)"
+ # libLLVM-3.8.0svn-r123456.so
+ ln -s "libLLVM-${_sover}.so" "${pkgdir}/usr/lib32/libLLVM-$(echo ${pkgver} | tr _ -).so"
_install_license
}