summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Galakhov2015-06-26 09:33:11 +0200
committerAlexey Galakhov2015-06-26 09:33:11 +0200
commite1b69ca504c4474dfaa970467001e883ed8edafa (patch)
treee0859390014fbc1f56f4d5cec344338d120ddfb0
downloadaur-e1b69ca504c4474dfaa970467001e883ed8edafa.tar.gz
Migrate from AUR3.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3afb636991d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lib32-log4cplus
+ pkgdesc = A C++ logger very close to Java's log4j
+ pkgver = 1.2.0rc2
+ pkgrel = 1
+ url = http://log4cplus.sourceforge.net/
+ arch = x86_64
+ license = GPL
+ depends = lib32-gcc-libs
+ source = http://downloads.sourceforge.net/log4cplus/log4cplus-1.2.0-rc2.tar.xz
+ sha256sums = b4cebe31af5c6dffcf511e17e8838c6f537bb673b3d0264d37c0514baf43189d
+
+pkgname = lib32-log4cplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a65c393dd9c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexey Galakhov <agalakhov at gmail dot com>
+
+_origname=log4cplus
+pkgname=lib32-log4cplus
+_origver=1.2.0-rc2
+pkgver=1.2.0rc2
+pkgrel=1
+pkgdesc="A C++ logger very close to Java's log4j"
+arch=('x86_64')
+url="http://log4cplus.sourceforge.net/"
+license=('GPL')
+depends=('lib32-gcc-libs')
+source=("http://downloads.sourceforge.net/${_origname}/${_origname}-${_origver}.tar.xz")
+sha256sums=('b4cebe31af5c6dffcf511e17e8838c6f537bb673b3d0264d37c0514baf43189d')
+
+package() {
+ cd ${srcdir}/${_origname}-${_origver}
+
+ make install DESTDIR=$pkgdir
+ rm -rf "${pkgdir}"/{etc,usr/{bin,include,share}}
+}
+
+build() {
+ cd ${srcdir}/${_origname}-${_origver}
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure \
+ --prefix=/usr \
+ --libdir='/usr/lib32' \
+ --with-working-locale
+
+ make
+}