summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorllde2020-05-11 23:21:11 +0200
committerllde2020-05-11 23:21:11 +0200
commit0f1025be96b67a7e10f31809249bf1e7f244ffe2 (patch)
tree25122afae14aef32f19f4d4c36217648970f6d5f
parent41f7f09ce26b3947663c5b2fda49b9d4632028f9 (diff)
downloadaur-0f1025be96b67a7e10f31809249bf1e7f244ffe2.tar.gz
Removed binary file, updated to 1.18, removed non needed patch, don't pass MAKEFLAGS directly to waf, added waf depend, replaced lib32-python with python makedepend added lv2 depend.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--lib32-lv2-1.16.0-1-x86_64.pkg.tar.xzbin166192 -> 0 bytes
-rw-r--r--lv2-1.16.0-fix_lv2_validate.patch62
4 files changed, 27 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea59ca463c6a..a5d1454b90cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = lib32-lv2
pkgdesc = Successor to the LADSPA audio plug-in standard
- pkgver = 1.16.0
+ pkgver = 1.18.0
pkgrel = 1
url = http://lv2plug.in/
arch = x86_64
license = LGPL
license = custom
- makedepends = lib32-python
+ makedepends = python
+ makedepends = waf
makedepends = lib32-libsndfile
makedepends = lib32-gtk2
- makedepends = lv2
- optdepends = libsndfile: Example sampler
- optdepends = gtk2: Example sampler
- optdepends = python2: Scripts
+ depends = lv2
+ optdepends = lib32-libsndfile: Example sampler
+ optdepends = lib32-gtk2: Example sampler
provides = lib32-lv2core
conflicts = lib32-lv2core
replaces = lib32-lv2core
- source = http://lv2plug.in/spec/lv2-1.16.0.tar.bz2
- source = lv2-1.16.0-fix_lv2_validate.patch
- sha512sums = ead6d590cded5dd7a548d6ffe0f2f9f8efadfa7bb9e8b4fa0aea6664ccdfbb3ca697514bddebe695a9442fba5b62714b5cd45c1bf7d0aaef12ffe50972c2d88c
- sha512sums = d0293d9599440db06066ef5c26bbef8195a4dc9cc9581036bf9a2b8fb96140e10f24ebd30f40cab62ee91acb70de8de17c7cc1dcf7b017736858aa12222df5bc
+ source = http://lv2plug.in/spec/lv2-1.18.0.tar.bz2
+ sha512sums = 9e8dd9c1f30371260d21efc105b1d4d4ad03d9e332d4d3877d873f20b9527bcd0e917ff23fc6e0a9cc4337bda85882c742f225f7cf4fbc8a8a0964565c91f9d9
pkgname = lib32-lv2
diff --git a/PKGBUILD b/PKGBUILD
index c3971c15cc26..1945bc48711c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,30 @@
_basename=lv2
pkgname=lib32-${_basename}
-pkgver=1.16.0
+pkgver=1.18.0
pkgrel=1
pkgdesc="Successor to the LADSPA audio plug-in standard"
url="http://lv2plug.in/"
license=('LGPL' 'custom')
arch=('x86_64')
-makedepends=('lib32-python' 'lib32-libsndfile' 'lib32-gtk2' 'lv2') #lib32-python should be more correct
-optdepends=('libsndfile: Example sampler'
- 'gtk2: Example sampler'
- 'python2: Scripts')
+depends=('lv2')
+makedepends=('python' 'waf' 'lib32-libsndfile' 'lib32-gtk2')
+optdepends=('lib32-libsndfile: Example sampler'
+ 'lib32-gtk2: Example sampler'
+ )
provides=('lib32-lv2core')
conflicts=('lib32-lv2core')
replaces=('lib32-lv2core')
-source=("http://lv2plug.in/spec/$_basename-$pkgver.tar.bz2"
- "lv2-1.16.0-fix_lv2_validate.patch"
- )
-sha512sums=('ead6d590cded5dd7a548d6ffe0f2f9f8efadfa7bb9e8b4fa0aea6664ccdfbb3ca697514bddebe695a9442fba5b62714b5cd45c1bf7d0aaef12ffe50972c2d88c'
- 'd0293d9599440db06066ef5c26bbef8195a4dc9cc9581036bf9a2b8fb96140e10f24ebd30f40cab62ee91acb70de8de17c7cc1dcf7b017736858aa12222df5bc'
-)
+
+source=("http://lv2plug.in/spec/$_basename-$pkgver.tar.bz2")
+sha512sums=('9e8dd9c1f30371260d21efc105b1d4d4ad03d9e332d4d3877d873f20b9527bcd0e917ff23fc6e0a9cc4337bda85882c742f225f7cf4fbc8a8a0964565c91f9d9')
build() {
cd "$srcdir/$_basename-$pkgver"
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
-
+
# let wscript(s) find the custom waf scripts
mkdir -pv tools
touch __init__.py
@@ -40,12 +38,19 @@ build() {
-e "s/load('autowaf'/load('autowaf', tooldir='tools'/g" \
-e "s/load('lv2'/load('lv2', tooldir='tools'/g" \
-i {,plugins/,plugins/*/}wscript
- patch -Np1 -i "../lv2-1.16.0-fix_lv2_validate.patch"
+
# --docs is currently broken: https://gitlab.com/lv2/lv2/issues/28
waf -vv configure --prefix=/usr \
--libdir=/usr/lib32 \
--test
- waf -vv build $MAKEFLAGS
+ waf -vv build
+}
+
+
+
+check() {
+ cd "$srcdir/$_basename-$pkgver"
+ waf test
}
package() {
diff --git a/lib32-lv2-1.16.0-1-x86_64.pkg.tar.xz b/lib32-lv2-1.16.0-1-x86_64.pkg.tar.xz
deleted file mode 100644
index 9f5bd38eb794..000000000000
--- a/lib32-lv2-1.16.0-1-x86_64.pkg.tar.xz
+++ /dev/null
Binary files differ
diff --git a/lv2-1.16.0-fix_lv2_validate.patch b/lv2-1.16.0-fix_lv2_validate.patch
deleted file mode 100644
index 3f2f727f689a..000000000000
--- a/lv2-1.16.0-fix_lv2_validate.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 51e6005c9f33a9dd6ac5004a09fcb6ffbdee8dee Mon Sep 17 00:00:00 2001
-From: Hanspeter Portner <dev@open-music-kontrollers.ch>
-Date: Sun, 24 Feb 2019 10:18:16 +0100
-Subject: [PATCH] Fix lv2_validate to use proper core.lv2 path
-
----
- plugins/eg-params.lv2/params.ttl | 6 +++---
- plugins/eg-sampler.lv2/sampler.ttl | 2 +-
- util/lv2_validate.in | 8 ++++----
- 3 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/plugins/eg-params.lv2/params.ttl b/plugins/eg-params.lv2/params.ttl
-index dbcf6aa4..931c8264 100644
---- a/plugins/eg-params.lv2/params.ttl
-+++ b/plugins/eg-params.lv2/params.ttl
-@@ -116,11 +116,11 @@ plug:spring
- state:state [
- plug:int 0 ;
- plug:long "0"^^xsd:long ;
-- plug:float 0.1234 ;
-+ plug:float "0.1234"^^xsd:float ;
- plug:double "0e0"^^xsd:double ;
- plug:bool false ;
- plug:string "Hello, world" ;
- plug:path <params.ttl> ;
-- plug:spring 0.0 ;
-- plug:lfo 0.0
-+ plug:spring "0.0"^^xsd:float ;
-+ plug:lfo "0.0"^^xsd:float
- ] .
-diff --git a/plugins/eg-sampler.lv2/sampler.ttl b/plugins/eg-sampler.lv2/sampler.ttl
-index 92570e5f..062b1772 100644
---- a/plugins/eg-sampler.lv2/sampler.ttl
-+++ b/plugins/eg-sampler.lv2/sampler.ttl
-@@ -57,7 +57,7 @@
- ] ;
- state:state [
- <http://lv2plug.in/plugins/eg-sampler#sample> <click.wav> ;
-- param:gain 1.0
-+ param:gain "1.0"^^xsd:float
- ] .
-
- <http://lv2plug.in/plugins/eg-sampler#ui>
-diff --git a/util/lv2_validate.in b/util/lv2_validate.in
-index 165b1bf7..2f9853df 100755
---- a/util/lv2_validate.in
-+++ b/util/lv2_validate.in
-@@ -72,10 +72,10 @@ sord_validate \
- "$LV2DIR/log.lv2/log.ttl" \
- "$LV2DIR/log.lv2/manifest.ttl" \
- "$LV2DIR/log.lv2/lv2-log.doap.ttl" \
-- "$LV2DIR/lv2core.lv2/manifest.ttl" \
-- "$LV2DIR/lv2core.lv2/lv2core.ttl" \
-- "$LV2DIR/lv2core.lv2/lv2core.doap.ttl" \
-- "$LV2DIR/lv2core.lv2/meta.ttl" \
-+ "$LV2DIR/core.lv2/manifest.ttl" \
-+ "$LV2DIR/core.lv2/lv2core.ttl" \
-+ "$LV2DIR/core.lv2/lv2core.doap.ttl" \
-+ "$LV2DIR/core.lv2/meta.ttl" \
- "$LV2DIR/eg-metro.lv2/manifest.ttl" \
- "$LV2DIR/eg-metro.lv2/metro.ttl" \
- "$LV2DIR/presets.lv2/manifest.ttl" \