summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlorenzo2017-08-24 23:23:30 +0200
committerlorenzo2017-08-24 23:23:30 +0200
commit4e5a169cd845be8df784817366f37a743529c71c (patch)
treedb2223aebe6749be82e17b0bd0ee6720d8f7b1ac
downloadaur-4e5a169cd845be8df784817366f37a743529c71c.tar.gz
first commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc2412eb1d64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lib32-lv2
+ pkgdesc = Successor to the LADSPA audio plug-in standard
+ pkgver = 1.14.0
+ pkgrel = 1
+ url = http://lv2plug.in/
+ arch = x86_64
+ license = LGPL
+ license = custom
+ makedepends = python2
+ makedepends = lib32-libsndfile
+ makedepends = lib32-gtk2
+ optdepends = libsndfile: Example sampler
+ optdepends = gtk2: Example sampler
+ optdepends = python2: Scripts
+ provides = lib32-lv2core
+ conflicts = lib32-lv2core
+ replaces = lib32-lv2core
+ source = http://lv2plug.in/spec/lv2-1.14.0.tar.bz2
+ md5sums = 0b56285a77aac3c93b50c36203aa91ee
+
+pkgname = lib32-lv2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7956f57af5e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+
+_basename=lv2
+pkgname=lib32-${_basename}
+pkgver=1.14.0
+pkgrel=1
+pkgdesc="Successor to the LADSPA audio plug-in standard"
+url="http://lv2plug.in/"
+license=('LGPL' 'custom')
+arch=('x86_64')
+makedepends=('python2' 'lib32-libsndfile' 'lib32-gtk2') #lib32-python should be more correct
+optdepends=('libsndfile: Example sampler'
+ 'gtk2: Example sampler'
+ 'python2: Scripts')
+provides=('lib32-lv2core')
+conflicts=('lib32-lv2core')
+replaces=('lib32-lv2core')
+source=("http://lv2plug.in/spec/$_basename-$pkgver.tar.bz2")
+md5sums=('0b56285a77aac3c93b50c36203aa91ee')
+
+build() {
+ cd "$srcdir/$_basename-$pkgver"
+ export CC="$CC -m32"
+ export CXX="$CXX -m32"
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ python2 waf configure --prefix=/usr --libdir=/usr/lib32
+ python2 waf build $MAKEFLAGS
+}
+
+package() {
+ cd "$srcdir/$_basename-$pkgver"
+#REMOVE includes and others
+ python2 waf install --destdir="$pkgdir"
+ rm ${pkgdir}/usr/bin ${pkgdir}/usr/include ${pkgdir}/usr/share -Rf
+}
+
+# vim:set ts=2 sw=2 et:
+