summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2016-05-28 08:16:41 -0300
committerRafael Fontenelle2016-05-28 08:16:41 -0300
commit56a86db16b776e854fbccbbf273e67e8079c9922 (patch)
tree810c2de0626a32c86288d41e9d758bfcd3512768
parenteccff7155d41cf6ed1f5f5165170350ebd16ffc6 (diff)
downloadaur-56a86db16b776e854fbccbbf273e67e8079c9922.tar.gz
Fix 32-bit compilation of libminilzo
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0071c4a7a4b..94f2c2eab2af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat May 28 11:15:50 UTC 2016
pkgbase = lib32-lzo
pkgdesc = Portable lossless data compression library (32 bit)
pkgver = 2.09
- pkgrel = 1
+ pkgrel = 2
url = http://www.oberhumer.com/opensource/lzo
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index dfa3eb005ba6..5b77974f97f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: josephgbr <rafael.f.f1@gmail.com>
+# Maintainer: rafaelff <rafaelff@gnome.org>
+
_pkgbase=lzo
pkgname=lib32-$_pkgbase
pkgver=2.09
-pkgrel=1
+pkgrel=2
pkgdesc="Portable lossless data compression library (32 bit)"
arch=('x86_64')
url="http://www.oberhumer.com/opensource/lzo"
@@ -22,8 +23,8 @@ build() {
make
# build minilzo
- gcc $CFLAGS -fpic -Iinclude/lzo -o minilzo/minilzo.o -c minilzo/minilzo.c
- gcc $LDFLAGS -g -shared -o libminilzo.so.0 -Wl,-soname,libminilzo.so.0 minilzo/minilzo.o
+ $CC $CFLAGS -fpic -Iinclude/lzo -o minilzo/minilzo.o -c minilzo/minilzo.c
+ $CC $LDFLAGS -g -shared -o libminilzo.so.0 -Wl,-soname,libminilzo.so.0 minilzo/minilzo.o
}
check() {