summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReza Jahanbakhshi2022-08-17 23:30:50 +0200
committerReza Jahanbakhshi2022-08-17 23:30:50 +0200
commit27ce090e10dd4703e4c4d6f5a290ab29e575b2bc (patch)
tree3b7bba18bba55a84a5f0ceca6d7c403034bd7f19
parente03c949fb4f44ac371d0f5e5d032f968e3c30449 (diff)
downloadaur-27ce090e10dd4703e4c4d6f5a290ab29e575b2bc.tar.gz
Forced usage of c++17 until upstream fix.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38964dbc47a9..7338695d9a84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 22.2.0_devel.156171.7bb62d9dd859.d41d8cd98f00b204e9800998ecf8427e
+ pkgver = 22.3.0_devel.157977.56bb29cb93ac.d41d8cd98f00b204e9800998ecf8427e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7b4014cfe1c8..0d073ad0384b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=lib32-mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=22.2.0_devel.156171.7bb62d9dd859.d41d8cd98f00b204e9800998ecf8427e
+pkgver=22.3.0_devel.158201.93fa687808f7.d41d8cd98f00b204e9800998ecf8427e
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
@@ -115,6 +115,8 @@ prepare() {
done
}
+# cpp_std=c++17 can be removed once https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17966 is merged
+
build () {
export CC="${CC:-gcc}"
export CXX="${CXX:-g++}"
@@ -126,6 +128,7 @@ build () {
meson setup mesa _build \
--native-file llvm32.native \
-D b_ndebug=true \
+ -D cpp_std=c++17 \
-D buildtype=plain \
--wrap-mode=nofallback \
-D prefix=/usr \