summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-09-10 16:51:03 +0200
committerLone_Wolf2021-09-10 16:51:03 +0200
commit017cc919ec79ee34fd286aab79caf07e0a4dc2b0 (patch)
treec330432d8d31171577226cacee497019d82b2a4f
parente632c45d458b8ac0b72ae1ee692a29d8d6613a72 (diff)
downloadaur-017cc919ec79ee34fd286aab79caf07e0a4dc2b0.tar.gz
patch added to solve build failure, see https://gitlab.freedesktop.org/mesa/mesa/-/issues/5320
-rw-r--r--.SRCINFO5
-rw-r--r--12715 - use hasParamAttr instead of hasAttribute.patch24
-rw-r--r--PKGBUILD10
3 files changed, 35 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f080d76f3f31..944405e3f405 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.3.0_devel.143549.688d11e4e82
+ pkgver = 21.3.0_devel.144688.2587fa1570e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -51,11 +51,14 @@ pkgbase = lib32-mesa-git
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main
source = LICENSE
source = llvm32.native
+ source = 12715 - use hasParamAttr instead of hasAttribute.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
md5sums = 6b4a19068a323d7f90a3d3cd315ed1f9
+ md5sums = 87cc71137f5fa8b686ff4f562dbf65d5
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
sha512sums = c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe
+ sha512sums = 47886f0916dbf68b5cad7cd6aacfc61955d1352bff9431b0958aa17b0280e18d03b3690be872f10156a1d206560b11cf8835446df82f118ffa138acd551e47b8
pkgname = lib32-mesa-git
diff --git a/12715 - use hasParamAttr instead of hasAttribute.patch b/12715 - use hasParamAttr instead of hasAttribute.patch
new file mode 100644
index 000000000000..067141ff4d42
--- /dev/null
+++ b/12715 - use hasParamAttr instead of hasAttribute.patch
@@ -0,0 +1,24 @@
+--- a/src/amd/llvm/ac_llvm_helper.cpp
++++ b/src/amd/llvm/ac_llvm_helper.cpp
+@@ -60,7 +60,7 @@
+ llvm::Argument *A = llvm::unwrap<llvm::Argument>(arg);
+ llvm::AttributeList AS = A->getParent()->getAttributes();
+ unsigned ArgNo = A->getArgNo();
+- return AS.hasAttribute(ArgNo + 1, llvm::Attribute::InReg);
++ return AS.hasParamAttr(ArgNo, llvm::Attribute::InReg);
+ }
+
+
+--- a/src/gallium/frontends/clover/llvm/codegen/common.cpp
++++ b/src/gallium/frontends/clover/llvm/codegen/common.cpp
+@@ -233,8 +233,8 @@ namespace {
+ }
+
+ } else {
+- const bool needs_sign_ext = f.getAttributes().hasAttribute(
+- arg.getArgNo() + 1, ::llvm::Attribute::SExt);
++ const bool needs_sign_ext = f.getAttributes().hasParamAttr(
++ arg.getArgNo(), ::llvm::Attribute::SExt);
+
+ args.emplace_back(module::argument::scalar, arg_api_size,
+ target_size, target_align,
diff --git a/PKGBUILD b/PKGBUILD
index 988e8c223106..56482a6f4b32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=lib32-mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.3.0_devel.143549.688d11e4e82
+pkgver=21.3.0_devel.144688.2587fa1570e
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
@@ -28,14 +28,17 @@ license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main'
'LICENSE'
'llvm32.native'
+ "12715 - use hasParamAttr instead of hasAttribute.patch"
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- '6b4a19068a323d7f90a3d3cd315ed1f9')
+ '6b4a19068a323d7f90a3d3cd315ed1f9'
+ '87cc71137f5fa8b686ff4f562dbf65d5')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- 'c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe')
+ 'c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe'
+ '47886f0916dbf68b5cad7cd6aacfc61955d1352bff9431b0958aa17b0280e18d03b3690be872f10156a1d206560b11cf8835446df82f118ffa138acd551e47b8')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -93,6 +96,7 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+ patch --directory=mesa --forward --strip=1 --input="${srcdir}/12715 - use hasParamAttr instead of hasAttribute.patch"
}
build () {