summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2016-07-21 03:15:07 +0200
committerLW-archlinux2016-07-21 03:15:07 +0200
commit1776d22ab6ccd77c60ecf788be9a46cf59fe85e3 (patch)
treed83cacbf15dca61476b5a5abd78681bcdbeab965
parent2dce7be86a0caaecba4ca2cba6e3110b2498ad3e (diff)
downloadaur-1776d22ab6ccd77c60ecf788be9a46cf59fe85e3.tar.gz
pthread-stubs patch updated & renamed
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--disable-pthread-stubs-on-linux.patch12
-rw-r--r--remove-libpthread-stubs.patch14
4 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25118f24db09..d16335abea8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version for multilib applications
- pkgver = 12.1.0_devel.82587.154c0a4
+ pkgver = 12.1.0_devel.83426.d2b4b16
pkgrel = 1
url = http://mesa3d.sourceforge.net
arch = x86_64
@@ -36,10 +36,10 @@ pkgbase = lib32-mesa-git
makedepends = lib32-libxvmc
source = mesa::git://anongit.freedesktop.org/mesa/mesa#branch=master
source = LICENSE
- source = remove-libpthread-stubs.patch
+ source = disable-pthread-stubs-on-linux.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
- md5sums = e417399ed46be7f61da7246503965b13
+ md5sums = a1435715781d62ce096295c5ce656d5c
pkgname = lib32-mesa-vdpau-git
pkgdesc = Mesa VDPAU drivers (32-bit)
diff --git a/PKGBUILD b/PKGBUILD
index c78cf83d1e2c..6333bbaf8a98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=lib32-mesa-git
pkgname=('lib32-mesa-vdpau-git' 'lib32-mesa-vulkan-intel-git' 'lib32-mesa-libgl-git' 'lib32-libva-mesa-driver-git' 'lib32-mesa-git')
pkgdesc="an open-source implementation of the OpenGL specification, git version for multilib applications"
-pkgver=12.1.0_devel.82587.154c0a4
+pkgver=12.1.0_devel.83426.d2b4b16
pkgrel=1
arch=('x86_64')
makedepends=('python2' 'lib32-libxml2' 'lib32-expat' 'lib32-libx11' 'glproto' 'lib32-libdrm>=2.4.66' 'dri2proto' 'dri3proto' 'presentproto'
@@ -25,14 +25,14 @@ url="http://mesa3d.sourceforge.net"
license=('custom')
source=('mesa::git://anongit.freedesktop.org/mesa/mesa#branch=master'
'LICENSE'
- 'remove-libpthread-stubs.patch')
+ 'disable-pthread-stubs-on-linux.patch')
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- 'e417399ed46be7f61da7246503965b13')
+ 'a1435715781d62ce096295c5ce656d5c')
prepare() {
cd ${srcdir}/mesa
- patch -Np1 -i ../remove-libpthread-stubs.patch
+ patch -Np1 -i ../disable-pthread-stubs-on-linux.patch
}
pkgver() {
diff --git a/disable-pthread-stubs-on-linux.patch b/disable-pthread-stubs-on-linux.patch
new file mode 100644
index 000000000000..09ca1fd2daac
--- /dev/null
+++ b/disable-pthread-stubs-on-linux.patch
@@ -0,0 +1,12 @@
+diff -aur mesa.a/configure.ac mesa.b/configure.ac
+--- mesa.a/configure.ac 2016-07-21 01:37:47.000000000 +0200
++++ mesa.b/configure.ac 2016-07-21 01:46:59.426168060 +0200
+@@ -825,7 +825,7 @@
+
+ dnl pthread-stubs is mandatory on targets where it exists
+ case "$host_os" in
+-cygwin* )
++cygwin* | linux* )
+ pthread_stubs_possible="no"
+ ;;
+ * )
diff --git a/remove-libpthread-stubs.patch b/remove-libpthread-stubs.patch
deleted file mode 100644
index 5b44d03cc4fd..000000000000
--- a/remove-libpthread-stubs.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur mesa-orig/configure.ac mesa-origb/configure.ac
---- mesa-orig/configure.ac 2016-05-25 15:37:44.191643017 +0200
-+++ mesa-origb/configure.ac 2016-05-25 15:42:20.861654709 +0200
-@@ -813,10 +813,6 @@
- dnl pkgconfig files.
- test -z "$PTHREAD_LIBS" && PTHREAD_LIBS="-lpthread"
-
--PKG_CHECK_MODULES(PTHREADSTUBS, pthread-stubs)
--AC_SUBST(PTHREADSTUBS_CFLAGS)
--AC_SUBST(PTHREADSTUBS_LIBS)
--
- dnl SELinux awareness.
- AC_ARG_ENABLE([selinux],
- [AS_HELP_STRING([--enable-selinux],