summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-09-20 11:01:41 +0200
committerLone_Wolf2021-09-20 11:01:41 +0200
commit45726b16e1722fcfd4a4f16531413b6b4c3bbc48 (patch)
tree1e32ea8ebe141c552863b6afc53c33408790b124
parentd615d571c9986d8939dbf0bccfe68f3d79a11941 (diff)
downloadaur-45726b16e1722fcfd4a4f16531413b6b4c3bbc48.tar.gz
patch included in upstream, removed
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
-rw-r--r--use hasParamAttr instead of hasAttribute.patch13
3 files changed, 4 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fc87a64e504..59925cb3aba0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.3.0_devel.144751.9c158fcc709
+ pkgver = 21.3.0_devel.145043.1a6c01a61b1
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -52,14 +52,11 @@ pkgbase = lib32-mesa-minimal-git
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
source = llvm32.native
- source = use hasParamAttr instead of hasAttribute.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
md5sums = 6b4a19068a323d7f90a3d3cd315ed1f9
- md5sums = 5fb1d94f0714863855e0c3d328f02ce4
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
sha512sums = c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe
- sha512sums = 4d46d93401efde3be3d879dfb92e3d79453788a87c326968901b1702fd2ba7bda155950b9ce2958320bb0dd6f89b71573610c9f75f809fb5296b9d1355fd1e75
pkgname = lib32-mesa-minimal-git
diff --git a/PKGBUILD b/PKGBUILD
index a4c9f82e0b56..822697ae9f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=lib32-mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.3.0_devel.144751.9c158fcc709
+pkgver=21.3.0_devel.145043.1a6c01a61b1
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
@@ -28,17 +28,16 @@ license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
'llvm32.native'
- "use hasParamAttr instead of hasAttribute.patch"
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
'6b4a19068a323d7f90a3d3cd315ed1f9'
- '5fb1d94f0714863855e0c3d328f02ce4')
+)
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
'c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe'
- '4d46d93401efde3be3d879dfb92e3d79453788a87c326968901b1702fd2ba7bda155950b9ce2958320bb0dd6f89b71573610c9f75f809fb5296b9d1355fd1e75')
+)
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -55,7 +54,6 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
- patch --directory=mesa --forward --strip=1 --input="${srcdir}/use hasParamAttr instead of hasAttribute.patch"
}
build () {
diff --git a/use hasParamAttr instead of hasAttribute.patch b/use hasParamAttr instead of hasAttribute.patch
deleted file mode 100644
index b9e64f5fb0c7..000000000000
--- a/use hasParamAttr instead of hasAttribute.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/gallium/frontends/clover/llvm/codegen/common.cpp
-+++ b/src/gallium/frontends/clover/llvm/codegen/common.cpp
-@@ -233,8 +233,8 @@ namespace {
- }
-
- } else {
-- const bool needs_sign_ext = f.getAttributes().hasAttribute(
-- arg.getArgNo() + 1, ::llvm::Attribute::SExt);
-+ const bool needs_sign_ext = f.getAttributes().hasParamAttr(
-+ arg.getArgNo(), ::llvm::Attribute::SExt);
-
- args.emplace_back(module::argument::scalar, arg_api_size,
- target_size, target_align,