summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-07-24 14:13:02 +0200
committerLone_Wolf2021-07-24 14:13:02 +0200
commita7b5439bd427fc32f17e8d438a82a03d2107d0fb (patch)
tree334ec80403aaa14c80de0f03a9165bb01f21a133
parent5273065b9dabb4103c2df286426c1d7f4d90baf0 (diff)
downloadaur-a7b5439bd427fc32f17e8d438a82a03d2107d0fb.tar.gz
upstream solved build failure, removed patch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
-rw-r--r--do-not-use-StackAlignmentOverride.patch13
3 files changed, 5 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82361d7b5771..c93243ec7b83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-mesa-minimal-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.2.0_devel.141308.50233d0daa3
+ pkgver = 21.3.0_devel.142889.bd9550b026e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -52,14 +52,11 @@ pkgbase = lib32-mesa-minimal-git
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
source = llvm32.native
- source = do-not-use-StackAlignmentOverride.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
md5sums = 6b4a19068a323d7f90a3d3cd315ed1f9
- md5sums = 72a79be875f9b5cba273590b55922b0d
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
sha512sums = c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe
- sha512sums = f1f2d93967756509aba883e6cc7a58dfdb59423b5bac0d7363c8585542e6813aa097ce7f22dafb9d1b7d9ceb5f179f48181d7509b831e3d46d13786e96778584
pkgname = lib32-mesa-minimal-git
diff --git a/PKGBUILD b/PKGBUILD
index 2b5183b78af7..28eb4ac811d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=lib32-mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.2.0_devel.141308.50233d0daa3
+pkgver=21.3.0_devel.142889.bd9550b026e
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
@@ -27,18 +27,14 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
- 'llvm32.native'
- 'do-not-use-StackAlignmentOverride.patch'
-)
+ 'llvm32.native')
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- '6b4a19068a323d7f90a3d3cd315ed1f9'
- '72a79be875f9b5cba273590b55922b0d')
+ '6b4a19068a323d7f90a3d3cd315ed1f9')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- 'c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe'
- 'f1f2d93967756509aba883e6cc7a58dfdb59423b5bac0d7363c8585542e6813aa097ce7f22dafb9d1b7d9ceb5f179f48181d7509b831e3d46d13786e96778584')
+ 'c7dbb390ebde291c517a854fcbe5166c24e95206f768cc9458ca896b2253aabd6df12a7becf831998721b2d622d0c02afdd8d519e77dea8e1d6807b35f0166fe')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -55,11 +51,6 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
-
- # build fails due to a change in llvm 13. only x86 32-bit uses the option , removing it as temp workaround seems safe.
- # https://gitlab.freedesktop.org/mesa/mesa/-/issues/4906
- cd mesa
- patch --forward --strip=1 --input="${srcdir}/do-not-use-StackAlignmentOverride.patch"
}
build () {
diff --git a/do-not-use-StackAlignmentOverride.patch b/do-not-use-StackAlignmentOverride.patch
deleted file mode 100644
index d0fb46f7aca3..000000000000
--- a/do-not-use-StackAlignmentOverride.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --unified --recursive --text mesa.org/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp mesa.new/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
---- mesa.org/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp 2021-06-18 12:47:17.096083970 +0200
-+++ mesa.new/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp 2021-06-18 12:51:39.656887107 +0200
-@@ -351,7 +351,8 @@
- */
- TargetOptions options;
- #if defined(PIPE_ARCH_X86)
-- options.StackAlignmentOverride = 4;
-+ // options.StackAlignmentOverride = 4;
-+ // fails with llvm 13 , see https://gitlab.freedesktop.org/mesa/mesa/-/issues/4906
- #endif
-
- builder.setEngineKind(EngineKind::JIT)