summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brodsky2016-02-19 09:32:36 +0000
committerKevin Brodsky2016-02-19 09:32:36 +0000
commit0774c6cd69e1f91608a188a3bb1d7df920cc02f4 (patch)
tree7c57ec6de1036eb0d93f712cc06a4f3e1a8c8014
parent122559ff1dcb5cdc70e74ce3abce68d381738a36 (diff)
downloadaur-0774c6cd69e1f91608a188a3bb1d7df920cc02f4.tar.gz
upkgpkg: lib32-ncurses5-compat-libs 6.0-3
Make the package behave as intended, and a lot of cleanup. There shouldn't be any conflict with lib32-ncurses (they can now be installed together). - Reflect changes made in lib32-ncurses 6.0-2 (do not build non-widec libraries and just create symlinks, additional build flags). - Cleanup dependencies, provides, conflicts.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD60
2 files changed, 17 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 896964992b99..a92f33e3fc08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
+# Generated by mksrcinfo v8
+# Fri Feb 19 09:30:59 UTC 2016
pkgbase = lib32-ncurses5-compat-libs
pkgdesc = System V Release 4.0 curses emulation library (32-bit), ABI 5
pkgver = 6.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.gnu.org/software/ncurses/
arch = x86_64
license = MIT
makedepends = gcc-multilib
- depends = lib32-glibc
- depends = ncurses
- provides = lib32-ncurses
- conflicts = lib32-ncurses
source = ftp://ftp.gnu.org/pub/gnu/ncurses/ncurses-6.0.tar.gz
md5sums = ee13d052e1ead260d7c28071f46eefb1
diff --git a/PKGBUILD b/PKGBUILD
index 2287f5591813..3e323d12266b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,80 +1,48 @@
-# $Id$
-# Maintainer: Laszlo Papp <lpapp@kde.org>
+# Maintainer: Kevin Brodsky <corax26 at gmail dot com>
_pkgbasename=ncurses
pkgname=lib32-${_pkgbasename}5-compat-libs
pkgver=6.0
_compatpkgver=5.9
-pkgrel=2
+pkgrel=3
pkgdesc="System V Release 4.0 curses emulation library (32-bit), ABI 5"
arch=('x86_64')
url="http://www.gnu.org/software/ncurses/"
license=('MIT')
-depends=('lib32-glibc' ${_pkgbasename})
makedepends=("gcc-multilib")
-conflicts=("lib32-ncurses")
-provides=("lib32-ncurses")
source=(ftp://ftp.gnu.org/pub/gnu/${_pkgbasename}/${_pkgbasename}-${pkgver}.tar.gz)
md5sums=('ee13d052e1ead260d7c28071f46eefb1')
build() {
- export CPPFLAGS="-P"
+ cd ${_pkgbasename}-${pkgver}
+
export CC="gcc -m32"
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
- cd ${srcdir}/
- mkdir -p ncurses{,w}-build
-
- cd ${srcdir}/ncursesw-build
- ../${_pkgbasename}-${pkgver}/configure --prefix=/usr --mandir=/usr/share/man \
- --with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=${pkgdir} --enable-widec --libdir=/usr/lib32 \
- --without-gpm --with-abi-version=5
- make
-
- # libraries for external binary support
- cd ${srcdir}/ncurses-build
-# [ $CARCH = "x86_64" ] && CONFIGFLAG="--with-chtype=long"
- ../${_pkgbasename}-${pkgver}/configure --prefix=/usr \
- --with-shared --with-normal --without-debug --without-ada \
- --with-install-prefix=${pkgdir} $CONFIGFLAG --libdir=/usr/lib32 \
- --without-gpm --with-abi-version=5
- make
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --with-shared --with-normal --without-debug --without-ada \
+ --with-install-prefix=${pkgdir} --enable-widec --libdir=/usr/lib32 \
+ --enable-ext-colors --enable-ext-mouse --without-gpm --with-abi-version=5
+ make
}
package() {
- cd ${srcdir}/ncursesw-build
+ cd ${_pkgbasename}-${pkgver}
make install
install -dm755 ${pkgdir}/usr/lib32
# fool packages looking to link to non-wide-character ncurses libraries
- for lib in curses ncurses form panel menu; do
- rm -f ${pkgdir}/usr/lib32/lib${lib}.so
- echo "INPUT(-l${lib}w)" >${pkgdir}/usr/lib32/lib${lib}.so
- ln -sf lib${lib}w.a ${pkgdir}/usr/lib32/lib${lib}.a
- done
- ln -sf libncurses++w.a ${pkgdir}/usr/lib32/libncurses++.a
-
- # some packages look for -lcurses during build
- rm -f ${pkgdir}/usr/lib32/libcursesw.so
- echo "INPUT(-lncursesw)" >${pkgdir}/usr/lib32/libcursesw.so
- ln -sf libncurses.so ${pkgdir}/usr/lib32/libcurses.so
- ln -sf libncursesw.a ${pkgdir}/usr/lib32/libcursesw.a
- ln -sf libncurses.a ${pkgdir}/usr/lib32/libcurses.a
-
- # non-widec compatibility libraries
- cd ${srcdir}/ncurses-build
for lib in ncurses form panel menu; do
- install -Dm755 lib/lib${lib}.so.${_compatpkgver} ${pkgdir}/usr/lib32/lib${lib}.so.${_compatpkgver}
- ln -s lib${lib}.so.${_compatpkgver} ${pkgdir}/usr/lib32/lib${lib}.so.5
+ ln -s lib${lib}w.so.5 "$pkgdir"/usr/lib32/lib${lib}.so.5
done
- rm -rf "${pkgdir}"/usr/{include,share,bin}
+ # Also remove .so symlinks and static libraries (conflicting with lib32-ncurses)
+ rm -rf "${pkgdir}"/usr/{include,share,bin,lib32/*.so,lib32/*.a}
+
mkdir -p "$pkgdir/usr/share/licenses"
ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
}
# vim: set et ts=2 sw=2:
-