summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVersus Void2016-09-23 13:56:45 +0300
committerVersus Void2016-09-23 13:56:45 +0300
commit0d461cc8c5cc7a9773f0e91cffc5375bf7710fdb (patch)
tree6eaf0d8301bc34e0e8a7694c82477262e737e3ac
downloadaur-0d461cc8c5cc7a9773f0e91cffc5375bf7710fdb.tar.gz
Initial
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD43
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a19d21d28637
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = lib32-net-snmp
+ pkgdesc = A suite of applications used to implement SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6
+ pkgver = 5.7.3
+ pkgrel = 3
+ url = http://www.net-snmp.org/
+ arch = x86_64
+ license = BSD
+ makedepends = python2-setuptools
+ depends = net-snmp
+ depends = lib32-openssl
+ depends = lib32-libnl
+ depends = lib32-pciutils
+ options = !emptydirs
+ options = !makeflags
+ source = http://downloads.sourceforge.net/net-snmp/net-snmp-5.7.3.tar.gz
+ source = http://downloads.sourceforge.net/net-snmp/net-snmp-5.7.3.tar.gz.asc
+ validpgpkeys = 8AAA779B597B405BBC329B6376CF47B8A77C5329
+ validpgpkeys = 27CAA4A32E371383A33ED0587D5F9576E0F81533
+ sha1sums = 97dc25077257680815de44e34128d365c76bd839
+ sha1sums = SKIP
+
+pkgname = lib32-net-snmp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6da53738c433
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+_pkgbasename=net-snmp
+pkgname=lib32-${_pkgbasename}
+pkgver=5.7.3
+pkgrel=3
+pkgdesc="A suite of applications used to implement SNMP v1, SNMP v2c and SNMP v3 using both IPv4 and IPv6"
+arch=('x86_64')
+url="http://www.net-snmp.org/"
+license=('BSD')
+depends=("${_pkgbasename}" 'lib32-openssl' 'lib32-libnl' 'lib32-pciutils')
+makedepends=('python2-setuptools')
+options=('!emptydirs' '!makeflags')
+source=(http://downloads.sourceforge.net/${_pkgbasename}/${_pkgbasename}-${pkgver}.tar.gz{,.asc})
+sha1sums=('97dc25077257680815de44e34128d365c76bd839'
+ 'SKIP')
+validpgpkeys=('8AAA779B597B405BBC329B6376CF47B8A77C5329'
+ '27CAA4A32E371383A33ED0587D5F9576E0F81533') # Net-SNMP Administrators
+
+build() {
+ cd ${_pkgbasename}-${pkgver}
+ CFLAGS="-m32" CPPFLAGS="-m32" PYTHONPROG=/usr/bin/python2 ./configure --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --enable-ucd-snmp-compatibility \
+ --enable-ipv6 \
+ --disable-embedded-perl \
+ --disable-perl-cc-checks \
+ --without-perl-modules \
+ --without-python-modules \
+ --with-default-snmp-version="3" \
+ --with-sys-contact="root@localhost" \
+ --with-sys-location="Unknown" \
+ --with-logfile="/var/log/snmpd.log" \
+ --with-mib-modules="host misc/ipfwacc ucd-snmp/diskio tunnel ucd-snmp/dlmod" \
+ --with-persistent-directory="/var/net-snmp"
+ make NETSNMP_DONT_CHECK_VERSION=1
+}
+
+package() {
+ cd ${_pkgbasename}-${pkgver}
+ sed -i -e "s:install --basedir=\$\$dir:install --basedir=\$\$dir --root=${pkgdir}:" Makefile
+ make DESTDIR="${pkgdir}" INSTALL_PREFIX="${pkgdir}" INSTALLDIRS=vendor install
+ rm -rf "${pkgdir}"/usr/{include,bin,sbin,share}
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}