summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlorenzo2017-08-24 20:07:10 +0200
committerlorenzo2017-08-24 20:07:10 +0200
commit8414bf5c46d73c99bd92a059479de9bcb34e457a (patch)
tree2767292e87eced51353dd0f46e8b85f17a4d43fe
downloadaur-8414bf5c46d73c99bd92a059479de9bcb34e457a.tar.gz
First version of the lib32-numactl package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d30313f00b8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lib32-numactl
+ pkgdesc = Simple NUMA policy support 32-bit version. Libraries only
+ pkgver = 2.0.11
+ pkgrel = 1
+ url = http://oss.sgi.com/projects/libnuma/
+ arch = x86_64
+ license = LGPL2.1
+ license = GPL2
+ depends = perl
+ depends = numactl
+ source = ftp://oss.sgi.com/www/projects/libnuma/download/numactl-2.0.11.tar.gz
+ md5sums = d3bc88b7ddb9f06d60898f4816ae9127
+ sha1sums = 0846670269824078a4eae8a977728175437b0da4
+
+pkgname = lib32-numactl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b1503ec6c55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Original Contributor Dan McGee <dan@archlinux.org>
+# Contributor: Florian Zeitz <florob at babelmonkeys dot de>
+# Mantainer: Lorenzo Ferrillo <lorenzofer at live dot it>
+_basename=numactl
+pkgname=lib32-numactl
+pkgver=2.0.11
+pkgrel=1
+pkgdesc="Simple NUMA policy support 32-bit version. Libraries only"
+arch=('x86_64')
+url="http://oss.sgi.com/projects/libnuma/"
+license=('LGPL2.1' 'GPL2')
+depends=('perl' 'numactl')
+source=(ftp://oss.sgi.com/www/projects/libnuma/download/$_basename-${pkgver/_/-}.tar.gz)
+md5sums=('d3bc88b7ddb9f06d60898f4816ae9127')
+sha1sums=('0846670269824078a4eae8a977728175437b0da4')
+
+build() {
+ export CC="$CC -m32"
+ export CXX="$CXX -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ cd "$srcdir/$_basename-${pkgver/_/-}"
+ ./configure --prefix=/usr --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd "$srcdir/$_basename-${pkgver/_/-}"
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir/usr/share/" "$pkgdir/usr/bin/" "$pkgdir/usr/include/"
+}
+