summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorllde2018-09-03 17:32:00 +0200
committerllde2018-09-03 17:32:00 +0200
commita2bbd28175aa37b764789ac61093bf2f72225c2d (patch)
treed1b906c4f59216e66a5c5ddc59dd2cd637133078
parent8414bf5c46d73c99bd92a059479de9bcb34e457a (diff)
downloadaur-a2bbd28175aa37b764789ac61093bf2f72225c2d.tar.gz
Fixed glibc 2.26
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--numactl-2.0.11-sysmacros.patch11
3 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d30313f00b8d..eb9585633b00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = lib32-numactl
pkgdesc = Simple NUMA policy support 32-bit version. Libraries only
pkgver = 2.0.11
- pkgrel = 1
+ pkgrel = 2
url = http://oss.sgi.com/projects/libnuma/
arch = x86_64
license = LGPL2.1
license = GPL2
depends = perl
depends = numactl
- source = ftp://oss.sgi.com/www/projects/libnuma/download/numactl-2.0.11.tar.gz
- md5sums = d3bc88b7ddb9f06d60898f4816ae9127
+ source = https://sources.archlinux.org/other/packages/numactl/numactl-2.0.11.tar.gz
+ source = numactl-2.0.11-sysmacros.patch
sha1sums = 0846670269824078a4eae8a977728175437b0da4
+ sha1sums = 5a9cff7cf1fe687e5be83de0a512325b923e3e21
pkgname = lib32-numactl
diff --git a/PKGBUILD b/PKGBUILD
index 3b1503ec6c55..e70b23e55751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,20 @@
_basename=numactl
pkgname=lib32-numactl
pkgver=2.0.11
-pkgrel=1
+pkgrel=2
pkgdesc="Simple NUMA policy support 32-bit version. Libraries only"
arch=('x86_64')
url="http://oss.sgi.com/projects/libnuma/"
license=('LGPL2.1' 'GPL2')
depends=('perl' 'numactl')
-source=(ftp://oss.sgi.com/www/projects/libnuma/download/$_basename-${pkgver/_/-}.tar.gz)
-md5sums=('d3bc88b7ddb9f06d60898f4816ae9127')
-sha1sums=('0846670269824078a4eae8a977728175437b0da4')
+source=('https://sources.archlinux.org/other/packages/numactl/numactl-2.0.11.tar.gz' 'numactl-2.0.11-sysmacros.patch')
+sha1sums=('0846670269824078a4eae8a977728175437b0da4' '5a9cff7cf1fe687e5be83de0a512325b923e3e21')
build() {
- export CC="$CC -m32"
- export CXX="$CXX -m32"
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
-
+ patch -Np0 -i ../numactl-2.0.11-sysmacros.patch
cd "$srcdir/$_basename-${pkgver/_/-}"
./configure --prefix=/usr --libdir=/usr/lib32
make
diff --git a/numactl-2.0.11-sysmacros.patch b/numactl-2.0.11-sysmacros.patch
new file mode 100644
index 000000000000..22067aa10b8e
--- /dev/null
+++ b/numactl-2.0.11-sysmacros.patch
@@ -0,0 +1,11 @@
+diff -ru numactl-2.0.11/affinity.c new/affinity.c
+--- numactl-2.0.11/affinity.c 2015-12-10 22:24:17.000000000 +0100
++++ new/affinity.c 2018-09-03 17:21:41.833719945 +0200
+@@ -39,6 +39,7 @@
+ #include <dirent.h>
+ #include <linux/rtnetlink.h>
+ #include <linux/netlink.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <ctype.h>
+ #include <assert.h>