summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-23 17:42:38 -0500
committerVincent Grande2020-12-23 17:42:38 -0500
commit7aea5fd48851960e9ef14ad4a35acc65f84792b9 (patch)
tree397fc61d6a12397a3017632096b91b978f95a612
downloadaur-7aea5fd48851960e9ef14ad4a35acc65f84792b9.tar.gz
initial upload
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD66
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3f6cbf86fe2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib32-pam-minimal-git
+ pkgdesc = Pluggable Authentication Modules
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = http://linux-pam.org
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = lib32-libnsl
+ depends = lib32-libtirpc
+ depends = lib32-libxcrypt
+ depends = pam
+ provides = lib32-pam
+ conflicts = lib32-pam
+ options = !emptydirs
+ source = git+https://github.com/linux-pam/linux-pam.git
+ b2sums = SKIP
+
+pkgname = lib32-pam-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad82b9de26c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: jtts <jussaar@mbnet.fi>
+# Contributor: josephgbr <rafael.f.f1@gmail.com>
+# Contributor: Janax <janax99@yahoo.com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=lib32-pam-minimal-git
+pkgver=1.5.1
+pkgrel=1
+pkgdesc='Pluggable Authentication Modules'
+arch=(x86_64)
+url=http://linux-pam.org
+license=(GPL2)
+depends=(
+ lib32-libnsl
+ lib32-libtirpc
+ lib32-libxcrypt
+ pam
+)
+makedepends=(git)
+source=(git+https://github.com/linux-pam/linux-pam.git)
+provides=(lib32-pam)
+conflicts=(lib32-pam)
+b2sums=(SKIP)
+options=(!emptydirs)
+
+pkgver() {
+ cd linux-pam
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd linux-pam
+
+ ./autogen.sh
+}
+
+build() {
+ cd linux-pam
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --sbindir=/usr/bin \
+ --disable-db \
+ --disable-doc \
+ --disable-debug \
+ --without-mailspool \
+ --disable-audit \
+ --disable-selinux \
+ --disable-regenerate-docu
+ make
+}
+
+package() {
+ make DESTDIR="${pkgdir}" SCONFIGDIR=/etc/security -C linux-pam install
+ rm -rf "${pkgdir}"/{etc,usr/{bin,include,lib,share}}
+}
+
+# vim: ts=2 sw=2 et: