summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2019-08-07 23:41:57 -0400
committerVincent Grande2019-08-07 23:41:57 -0400
commit33dcd3161c94df38914f1001b1627807762c2a32 (patch)
tree81826cb4d42e93f559f9abd7e911f2cb446824ea
downloadaur-33dcd3161c94df38914f1001b1627807762c2a32.tar.gz
things
-rw-r--r--.SRCINFO23
-rwxr-xr-xPKGBUILD47
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3dc620ea865
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = lib32-pango-git
+ pkgdesc = A library for layout and rendering of text (32-bit)
+ pkgver = 1.44.2
+ pkgrel = 1
+ epoch = 1
+ url = https://www.pango.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = meson
+ depends = lib32-libthai
+ depends = lib32-cairo
+ depends = lib32-libxft
+ depends = lib32-harfbuzz
+ depends = lib32-fribidi
+ depends = pango
+ provides = lib32-pango
+ conflicts = lib32-pango
+ source = git+https://gitlab.gnome.org/GNOME/pango.git
+ sha256sums = SKIP
+
+pkgname = lib32-pango-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ba842249e3e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Biru Ionut <ionut@archlinux.ro>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
+
+pkgname=lib32-pango-git
+pkgver=1.44.2
+pkgrel=1
+epoch=1
+pkgdesc="A library for layout and rendering of text (32-bit)"
+url="https://www.pango.org/"
+arch=(x86_64)
+license=(LGPL)
+provides=(lib32-pango)
+conflicts=(lib32-pango)
+depends=(lib32-libthai lib32-cairo lib32-libxft lib32-harfbuzz lib32-fribidi pango)
+makedepends=(git meson)
+#checkdepends=(ttf-dejavu cantarell-fonts)
+source=("git+https://gitlab.gnome.org/GNOME/pango.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pango
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd pango
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ arch-meson pango build --libdir=/usr/lib32 -D introspection=false
+ ninja -C build
+}
+
+#check() {
+# meson test -C build --print-errorlogs
+#}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ rm -r "$pkgdir"/usr/{bin,include}
+}